Bug 7029 - Intellisense not working on linked files
Summary: Intellisense not working on linked files
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Project Model ()
Version: Trunk
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: ---
Assignee: Lluis Sanchez
URL:
Depends on:
Blocks:
 
Reported: 2012-09-10 05:38 UTC by Dylan
Modified: 2016-12-07 09:31 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Dylan 2012-09-10 05:38:39 UTC
I have linked files that are all committed in using Subversion. In a separate instance of MonoDevelop I pull the latest version of the solution which updates a few of the files. In the other instance of MonoDevelop (that has links to those files that have just been updated in the linked solution) the intellisense does not update with the new methods or properties. 

version: 3.0.4.6
Comment 1 Mikayla Hutchinson [MSFT] 2012-09-10 16:05:00 UTC
It looks like the second instance of MD hasn't detected that the files changed. But I'm not sure whether this is the job of the project system or the subversion VCS system, or whether the C# parser isn't subscribing to the events correctly.

If you have the files open in the other instance of MonoDevelop, does the source editor detect that they changed?
Comment 2 Mike Krüger 2012-09-11 02:40:43 UTC
@mhutch: It's subscribed to file change events. I think it is the code that checks for file changes when the IDE gets focus - it should handle links.
Comment 3 Mike Krüger 2012-10-18 02:26:45 UTC
I think it's the project system - it should keep a table of the file links and yield file changed events for linked files as well.
Comment 4 tcab 2013-09-25 21:22:02 UTC
The latest Xamarin studio (as of September 2013) has the same bug.  Linking to a file and intellisense not seeing the relevant namespace.  Rebooting Xamarin Studio fixes the problem.

I've described the problem in great detail - scroll to the bottom of http://forums.xamarin.com/discussion/8150/linking-to-core-files-official-instructions-don-t-work-and-xamarin-studio-alpha-bugs where the title is "THE BUG WHERE XAMARIN STUDIO DOESN'T SEE LINKED NAMESPACES".  A clear reproducible set of steps is offered.

Hopefully this now provides all the information needed to make progress on this bug which seems to have been reported a year ago.
Comment 5 Lluis Sanchez 2016-12-01 15:19:11 UTC
Updating status.
Comment 6 David Karlaš 2016-12-07 09:31:58 UTC
I tried adding linked file to 4 additional projects and modifying linked file and changes were correctly reflected across all projects. I'm closing this as not reproducible. This was mostly likely fixed over past 3 years.