Bug 6979 - The MonoDevelop updater keeps trying to downgrade me from Mono 2.10.10 to mono 2.10.9
Summary: The MonoDevelop updater keeps trying to downgrade me from Mono 2.10.10 to mon...
Status: RESOLVED FEATURE
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Updater ()
Version: unspecified
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-09-07 06:27 UTC by Alan McGovern
Modified: 2012-09-07 13:08 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FEATURE

Description Alan McGovern 2012-09-07 06:27:11 UTC
As per title, MonoDevelop keeps trying to downgrade me. Is this expected because 2.10.10 is not on the update channel? I'm worried that if I install any updates from MonoDevelop, it will overwrite my 2.10.10 installation with 2.10.9 by rewriting the Mono.Framework/Version/Current symlink.

This happens with MonoDevelop 3.0.4.3
Comment 1 Mikayla Hutchinson [MSFT] 2012-09-07 11:13:13 UTC
The updater always tries to make the products match the versions on your current update channel. Only the sets of packages in the channel are supported. If you want an unsupported configuration, you must download and install packages manually.
Comment 2 Alan McGovern 2012-09-07 11:20:43 UTC
Can we get clickable links in the updater ui so that individual packages can be downloaded manually?