Bug 6966 - Repeatedly calling ShowDialog crashes Mono on OSX
Summary: Repeatedly calling ShowDialog crashes Mono on OSX
Status: NEW
Alias: None
Product: Class Libraries
Classification: Mono
Component: Windows.Forms ()
Version: unspecified
Hardware: Macintosh Mac OS
: Lowest normal
Target Milestone: Community
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-09-06 19:49 UTC by hsander
Modified: 2017-09-01 11:56 UTC (History)
3 users (show)

Tags: mono-community
Is this bug a regression?: ---
Last known good build:


Attachments
Screenshots and program illustrating bug (186.51 KB, application/pdf)
2012-09-06 19:49 UTC, hsander
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 6966 on GitHub or Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: GitHub Markdown or Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
NEW

Description hsander 2012-09-06 19:49:32 UTC
Created attachment 2467 [details]
Screenshots and program illustrating bug

A very simple example (see code attached) where the default AboutBox is shown with “ShowDialog(this)” works without issues under Mono on Linux and Windows.  However, when run under OSX using “mono MonoDialogTest.exe”, artifacts start to appear when the ShowDialog function is called repeatedly (~5 times in 10 seconds).  After several more times the application crashes and Mono needs to be force quit.  Screenshots and program attached.  This bug affects other applications I've run under Mono on Mac.  Try running your favorite program under Mono on a Mac and click "File>Open" a dozen times relatively quickly.
Comment 1 Zoltan Varga 2012-09-07 14:50:07 UTC
-> winforms.
Comment 2 hsander 2012-09-23 23:33:10 UTC
Bump...  
This bug seems to affect EVERY application that uses winforms with mono on osx. 
I can't think of a workaround other than not to use any forms in the application.
Comment 3 me 2017-08-28 03:57:57 UTC
Bump (5 years later!).
This still seems to be a serious issue, especially when more than one modal dialog is active at the same time, or if a modal dialog is invoked from another modal dialog.