Bug 6945 - MFA for VS2012(RC)'s Debugging Experience Not Good
Summary: MFA for VS2012(RC)'s Debugging Experience Not Good
Status: VERIFIED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Android ()
Version: 1.2.x
Hardware: Other Other
: Normal normal
Target Milestone: ---
Assignee: dean.ellis
URL:
Depends on:
Blocks:
 
Reported: 2012-09-06 07:24 UTC by Imgen Tata
Modified: 2015-07-30 02:55 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Imgen Tata 2012-09-06 07:24:17 UTC
Description of Problem:
MFA 4.2.5 on VS2012 RC + Win8 RP. When debugging, it takes quite a while to go into the debugging state and you can not use compound expression in Watch window like button.Text, it will become Text and will not evaluate. 

Steps to reproduce the problem:
1. Start VS2012 debugging for MFA project, setup a breakpoint, hit the breakpoint
2. Input a compound variable in the Watch window like button.Text


Actual Results:
The button.Text becomes just Text and will not evaluate next time the breakpoint is hit

Expected Results:
button.Text keeps being button.Text and should always evaluate correctly

How often does this happen? 
Everytime

Additional Information:
I'm using the emulator for the debugging
Comment 1 Arpit Jha 2015-07-30 02:55:03 UTC
I have checked this issue with XVS 3.11.666 and it works fine at my end .

For now I am closing this issue.

Screencast : http://www.screencast.com/t/Mt1JGLPc
Feel free to reopen if You are facing this issue again.


Environment Info:
Microsoft Visual Studio Professional 2012
Version 11.0.50727.1 RTMREL
Microsoft .NET Framework
Version 4.6.00057

Installed Version: Professional

Xamarin   3.11.823.0 (079165f)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

Xamarin.Android   5.1.5.3 (f98871a95a479f6d71b3067b7e5834d41fcb2118)
Visual Studio plugin to enable development for Xamarin.Android.

Xamarin.Forms Intellisense   1.0
Provides intellisense for Xamarin.Forms in the XML editor.

Xamarin.iOS   8.10.4.0 (1ebb3ca75e5ea92595284cb84c7d29c6e09ce324)
Visual Studio extension to enable development for Xamarin.iOS.

Xamarin.iOS Unified Migration   1.0
Automated migration for Xamarin iOS Classic projects to Unified

Xamarin.TestCloud.Integration   1.0
Early preview of Xamarin Test Cloud integration