Bug 6862 - Smart semicolon placement does not work on empty parameter call
Summary: Smart semicolon placement does not work on empty parameter call
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Text Editor ()
Version: 3.0.x
Hardware: Macintosh Mac OS
: Low normal
Target Milestone: ---
Assignee: Mike Krüger
URL:
Depends on:
Blocks:
 
Reported: 2012-09-03 10:29 UTC by Simon CORSIN
Modified: 2012-09-06 06:27 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Simon CORSIN 2012-09-03 10:29:35 UTC
Hello MonoTouch users and developers,

The title is pretty self-explanatory, when I type the semicolon between two parenthesis on a function call, it doesn't work if no arguments are specified.

Example : 

If I type "this.method(", the other ')' will appear, but pressing ';' then will not move it to the end of the line, and the final statement will result in "this.method(;)".

OS : OS X 10.8.1
MonoDevelop : 3.0.3.5
Comment 1 Mike Krüger 2012-09-06 06:27:22 UTC
fixed