Bug 676 - MonoDevelop 2.6 doesn't migrate user settings from 2.4
Summary: MonoDevelop 2.6 doesn't migrate user settings from 2.4
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: Trunk
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2011-09-08 10:51 UTC by Jeffrey Stedfast
Modified: 2011-11-15 14:19 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Jeffrey Stedfast 2011-09-08 10:51:36 UTC
A user on the MonoTouch mailing-list pointed out that when he upgraded to MonoDevelop 2.6, his keybindings were lost (and likely other settings as well).

In reality they weren't lost (MD 2.6 just uses a different settings directory than 2.4 did), but the perception is that they were.

MonoDevelop should probably offer to migrate a user's previous settings the first time it is run (and/or possibly even offer to do it at any point? I don't know).

This will likely also be a problem for users when they upgrade to 2.8 which is why I've marked it as Version=Trunk.
Comment 1 Mikayla Hutchinson [MSFT] 2011-09-08 10:56:29 UTC
It migrates settings automatically. Do you have a repro for cases where it doesn't?
Comment 2 Jeffrey Stedfast 2011-09-08 11:32:28 UTC
I don't, no. Might have to ask the guy on the MonoTouch mailing-list for a repro case.

I've asked him to get you what version of MonoDevelop he was running before. Hopefully he responds. If not, I guess we can close this.
Comment 3 Lluis Sanchez 2011-11-15 14:19:49 UTC
This is already fixed.