Bug 6688 - Intellisense failing to load in do while loop
Summary: Intellisense failing to load in do while loop
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: C# Binding ()
Version: 3.0.x
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: ---
Assignee: Mike Krüger
URL:
Depends on:
Blocks:
 
Reported: 2012-08-25 03:53 UTC by Brad Moore
Modified: 2012-08-28 02:01 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Brad Moore 2012-08-25 03:53:51 UTC
Issue happens when using MonoTouch. Creating a do/while loop intellisense works fine inside it.

do
{
	UIAlertView alert = new UIAlertView( // can use intellisense here
} while (true);


But it used within a delegate intellisense breaks.

StyledStringElement button = new StyledMultilineElement("test");
button.Tapped += delegate {
	do
	{
		UIAlertView alert = new UIAlertView( // intellisense fails to work
	} while (true);
};


Note: that making an alert inside a do/while seems silly, I have since changed my code but decided to file a bug anyway.
Comment 1 Mike Krüger 2012-08-28 00:58:44 UTC
Good that you've filed a bug it exposed a bug in our control flow graph builder :)

/fixed.
Comment 2 Brad Moore 2012-08-28 01:15:08 UTC
Hooray, I'm helping! /zoidberg
Comment 3 Mike Krüger 2012-08-28 02:01:45 UTC
YMMD :)