Bug 6655 - Debugging Enumerables no longer shows items (MonoTouch 5.3.5, OSX 10.8)
Summary: Debugging Enumerables no longer shows items (MonoTouch 5.3.5, OSX 10.8)
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Debugger ()
Version: unspecified
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Jeffrey Stedfast
URL:
Depends on:
Blocks:
 
Reported: 2012-08-22 21:35 UTC by Andy
Modified: 2012-09-06 14:28 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Andy 2012-08-22 21:35:05 UTC
Whenever I am debugging an enumeration (including dictionaries, lists, etc.), there used to be an accessor to so the individual items (in the case of a dictionary, the items in the Keys and Values properties).  I no longer see this in MonoTouch 5.3.5 on OSX 10.8.
Comment 1 Jeffrey Stedfast 2012-09-06 14:28:55 UTC
Fixed in git master and should be in a 3.0.4.6 (if made)