Bug 6650 - Dispose not being called when exiting using block when using LLVM
Summary: Dispose not being called when exiting using block when using LLVM
Status: RESOLVED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: General ()
Version: 5.2
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Zoltan Varga
URL:
Depends on:
Blocks:
 
Reported: 2012-08-22 14:22 UTC by David Merriman
Modified: 2014-11-18 22:18 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Comment 5 Zoltan Varga 2012-08-23 01:43:26 UTC
Are you using the 'Use LLVM optimizing compiler' option ?
Comment 6 David Merriman 2012-08-23 11:52:16 UTC
We are using LLVM.
Comment 7 Zoltan Varga 2012-08-23 11:54:16 UTC
And does turning that off fixes the problem ?
Comment 8 David Merriman 2012-08-23 12:27:53 UTC
Yes, actually, it does.
Comment 9 David Merriman 2012-09-10 14:18:06 UTC
Is anybody working on this bug?  I gather from our discussion that this is a problem with the LLVM compiler.  Turning off LLVM is just not an option for us; we are close to release, and as you can imagine, swapping out the compiler at the last minute is a little risky.  Can I get an update on what's being done on this issue?
Comment 10 Zoltan Varga 2012-09-10 14:49:16 UTC
Committed a workaround to mobile-master in 6e2a2668caf337c0e4cbd683d7c561756c4dc3a9.
Comment 11 David Merriman 2012-09-10 15:19:19 UTC
What does that mean for us?  When would this workaround be available in a stable release?
Comment 12 Zoltan Varga 2012-09-12 10:54:35 UTC
Can somebody answer the question above ?
Comment 13 Rolf Bjarne Kvinge [MSFT] 2012-09-12 18:17:09 UTC
David: there should be another stable release (with this fix) at latest by the end of next week.
Comment 14 Zoltan Varga 2012-09-14 21:59:23 UTC
This is not fixed, there is only a workaround. David, could you share the binaries with vargaz@xamarin.com on google drive ?
Comment 15 Rolf Bjarne Kvinge [MSFT] 2012-09-26 16:34:58 UTC
Bug #7449 might be related to this one.
Comment 16 Zoltan Varga 2014-11-18 22:18:01 UTC
-> FIXED.