Bug 6600 - mmp does not allow for sgen
Summary: mmp does not allow for sgen
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Mac Add-in ()
Version: 3.0.x
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Jeffrey Stedfast
URL:
Depends on:
Blocks:
 
Reported: 2012-08-18 19:25 UTC by Jonathan Brodsky
Modified: 2012-09-11 15:25 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Jonathan Brodsky 2012-08-18 19:25:40 UTC
I am porting an application that needs sgen for performance reasons, and monomac (and mmp) doesn't allow me to use it. I tried setting the MONO_ENV_OPTIONS before running the app, and also calling the built binary with the command line switch. Neither method did it.

I am guessing this is because the binary that is produced links in libmono and not libmono-sgen.
Comment 1 Jeffrey Stedfast 2012-09-11 13:30:10 UTC
Implemented in git master by adding a -sgen option

In the meantime, you can grab http://files.xamarin.com/~jeff/mmp to replace /Applications/MonoDevelop.app/Contents/MacOS/lib/monodevelop/AddIns/MonoDevelop.MonoMac/mmp

If you go to the "Advanced" tab in the Mac OS X Packaging Options dialog, you can specify Extra Arguments; just add: -sgen

That should work.
Comment 2 Jonathan Brodsky 2012-09-11 15:25:40 UTC
thanks much!