Bug 6565 - EditText password does not show dots when it is a child of a ListView
Summary: EditText password does not show dots when it is a child of a ListView
Status: RESOLVED NORESPONSE
Alias: None
Product: Android
Classification: Xamarin
Component: Mono runtime / AOT Compiler ()
Version: 4.2.x
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-08-16 14:37 UTC by Scott
Modified: 2013-12-05 18:36 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description Scott 2012-08-16 14:37:10 UTC
I am building my UI programmatically (dynamically).
I have a ListView which contains a number of fields.
One of those fields is an EditText control.
I want this control to have password behavior and to show dots after entering password characters.
Instead, no dots show at all.

Currently, I use the following APIs but to no avail:
_password.TransformationMethod = PasswordTransformationMethod.Instance;
           _password.InputType = InputTypes.ClassText | InputTypes.TextVariationPassword; 

It is my belief that the ListView is preventing the text transformation from occurring.
Prior to this, I could not even see characters entered into the EditText controls until I set the ListView's property DescendantFocusability to DescendantFocusability.AfterDescendants.  This change enabled me to see what was being typed as the characters are entered instead of having to lose field focus to see the entered text.  However, this change doesn't seem to work with the transformation of chars to dots.

Can anyone help me?  I believe that there might be a bug here.
Comment 1 Atsushi Eno 2012-09-20 23:55:00 UTC
I believe it is highly unlikely that it is a framework bug, but could you anyways provide your project so that we might be able to help? There are many variation of use of widget and code so we won't be able to create any relevant reproducible code for whatever you have.
Comment 2 RedHotPeter 2012-11-30 17:43:57 UTC
@Scott 

Did you have any luck fixing your issue?

I am also seeing the same behavior. I have tried programmatically creating an EditText widget, setting the InputType to TextVariationPassword, and adding it to a ListView item. However it always displays the plain text as the user types in the password.

-Peter
Comment 3 Scott 2012-12-03 07:39:31 UTC
@RedHotPeter

No, I did not have any luck fixing this issue.
As a workaround, I used a LinearLayout to organize my login controls.
Comment 4 PJ 2013-11-19 17:05:46 UTC
This bug has been in the NEEDINFO state with no changes for the last 90 days. Can we put this back into the NEW or CONFIRMED state, or are we still awaiting response?

If there is no change in the status of this bug over the next two weeks, this bug will be marked as NORESPONSE.
Comment 5 PJ 2013-12-05 18:36:14 UTC
This bug has not been changed from the NEEDINFO state since my previous comment, marking as RESOLVED NORESPONSE.

Please feel free to REOPEN this bug at any time if you are still experiencing the issue. Please add the requested information and set the bug back to the NEW (or CONFIRMED) state.