Bug 6551 - Bug in NSUrl Constructor (string,string)
Summary: Bug in NSUrl Constructor (string,string)
Status: RESOLVED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: General ()
Version: 5.3.x
Hardware: PC Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-08-16 06:35 UTC by Dermot
Modified: 2012-09-15 21:52 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Dermot 2012-08-16 06:35:36 UTC
When I attempt to use the overloaded constructor of NSUrl(string path,string relativeToUrl) I get an Invalid Selector error. Is it possible this isn't bound correctly?
Comment 1 Sebastien Pouliot 2012-08-16 08:48:33 UTC
I do not get an exception when using the `NSUrl(string path,string relativeToUrl)` constructor in my tests.

Can you tell me the exact version of MT / MD / Xcode / iOS you're using ? and whether this occurs on the simulator, devices (or both) ?

And also copy/paste the string values and the whole stack trace you get ?

Thanks
Comment 2 Sebastien Pouliot 2012-09-04 11:45:47 UTC
We're about to release 5.4 (stable). Do you have a test case for this issue ? if so can you supply it with the above information ? thanks!
Comment 3 Dermot 2012-09-15 21:52:38 UTC
I believe this must of been a problem with my implementation, as it is no longer occurring.