Bug 6545 - Changing the background colour on a grouped tableview with monotouch.dialog does nothing
Summary: Changing the background colour on a grouped tableview with monotouch.dialog d...
Status: RESOLVED DUPLICATE of bug 7362
Alias: None
Product: iOS
Classification: Xamarin
Component: General ()
Version: 5.99.x
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-08-15 15:33 UTC by gavin
Modified: 2012-09-21 09:27 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 7362

Description gavin 2012-08-15 15:33:43 UTC
I have code in mono touch 5.x that changes the background colour of a grouped dialogViewController.  The code run under 5.99 doesn't change the colour at all and it remains the default 'grey' background
Comment 1 Sebastien Pouliot 2012-09-05 10:18:01 UTC
Can you be more precise on which version of MonoTouch you code was working ?

And also which versions of iOS were used (in both the working and non-working cases) ?
Comment 2 Brad Moore 2012-09-20 18:34:27 UTC
Issue still exists in when I updated to MonoTouch 6.0, but unsure if MT is to blame.

When using XCode 4.4.1 (iOS5 simulator) everything is fine.
When using XCode 4.5 GM (iOS6 simulator) it does not work.
(Both when using MonoTouch 6.0)
 

Subclassing DialogViewController and overriding the ViewWillAppear (or ViewDidLoad, tested with both)

public override void ViewWillAppear(bool animated)
{
	base.ViewWillAppear(animated);

	TableView.BackgroundColor = UIColor.Green;
	TableView.SeparatorStyle = UITableViewCellSeparatorStyle.None;
	TableView.SeparatorColor = UIColor.Black;

	View.BackgroundColor = UIColor.Red;
}

The screen will stay at stripey grey pattern.
Comment 3 Brad Moore 2012-09-20 20:46:29 UTC
https://github.com/ytn3rd/random-code-things/tree/master/TestColor

Was discussing with martinbowling on IRC, the code sample seems to work for him using the iOS6 simulator.
Comment 4 Sebastien Pouliot 2012-09-21 08:38:19 UTC
Could you try to solution from #7362 ?
Comment 5 Brad Moore 2012-09-21 09:26:06 UTC
I can confirm that 

TableView.BackgroundView = null;

indeed does the trick!
Comment 6 Sebastien Pouliot 2012-09-21 09:27:28 UTC
merging with 7362

*** This bug has been marked as a duplicate of bug 7362 ***