Bug 6516 - Android SDK location is empty
Summary: Android SDK location is empty
Status: RESOLVED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Android ()
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-08-13 13:46 UTC by Allie Miller
Modified: 2016-08-03 15:23 UTC (History)
7 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Allie Miller 2012-08-13 13:46:50 UTC
Upon installing Mono for Android, receives the following error message when running Visual Studio:

There was an error attempting to initialize the MonoAndroidPackage:

System.ArgumentNullException: Value cannot be null.
Parameter name: path1
at System.IO.Path.Combine(String path1, String path2)
at Xamarin.AndroidTools.AndroidSdk.get_AdbExe()
at Mono.Android.VisualStudio.MonoAndroidDeviceManager..ctor()
at Mono.Android.VisualStudio.MonoAndroidSdk.get_DeviceManager()
at Mono.Android.VisualStudio.MonoAndroidPackage.Initialize()


Would also like to show a proper error message such as "Please set the Android SDK location in the Mono for Android settings" if error occurs in future.
Comment 1 Marek Habersack 2012-08-13 14:06:43 UTC
Fixed in git
Comment 9 Sebastian Krysmanski 2012-11-29 06:38:06 UTC
Is this fixed in the upcoming MfA 4.4?