Bug 6479 - Toolbox loader is broken
Summary: Toolbox loader is broken
Status: NEEDINFO
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Project Management ()
Version: Trunk
Hardware: PC Mac OS
: Normal normal
Target Milestone: master
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-08-08 17:19 UTC by Mikayla Hutchinson [MSFT]
Modified: 2017-08-24 21:00 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 6479 on Developer Community or GitHub if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
NEEDINFO

Description Mikayla Hutchinson [MSFT] 2012-08-08 17:19:56 UTC
The ToolboxItem loader does not work any more.

It's failing with the following problem:
System.IO.FileNotFoundException: Could not load file or assembly 'MonoDevelop.AspNet, Version=2.6.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies. The system cannot find the file specified.
File name: 'MonoDevelop.AspNet, Version=2.6.0.0, Culture=neutral, PublicKeyToken=null'
  at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke (System.Runtime.Remoting.Proxies.RealProxy rp, IMessage msg, System.Exception& exc, System.Object[]& out_args) [0x001f0] in /private/tmp/monobuild/build/BUILD/mono-2.10.9/mcs/class/corlib/System.Runtime.Remoting.Proxies/RealProxy.cs:247 

This exception is currently completely obscured by a catch {} on IToolboxLoader.cs line 97.

Note also that the exception on Windows is that it can't load MonoDevelop.DesignerSupport, which implies it's not handling remoting assembly identity correctly.
Comment 1 Mikayla Hutchinson [MSFT] 2012-08-08 20:01:40 UTC
The are also some other serious problems:
1) the Toolbox.xml records which loaders have been loaded, and caches the results, and never updates them. So, adding the 4.0 assemblies to the loader won't work on existing systems.
2) the AspNetToolboxLoader only seems to be resolving the 2.0 assemblies
3) it doesn't have 4.0 framework support

I suspect 2 and 3 are easy enough to fix, but 1 will be more work.

Regarding the basic bug, I suggest we rip out the broken external loader mechanism, complete the unfinished/unused CecilToolboxItemLoader base class (and simplify it by limiting what it can handle), port AspNetToolboxLoader to CecilToolboxItemLoader base class, special case WebControlToolboxItem in the AspNetToolboxLoader.
Comment 2 Will Smith 2017-08-24 21:00:20 UTC
Thanks so much for taking the time to submit this report! I’m unable to reproduce this issue using the latest Visual Studio 2017 for Mac Preview version 7.2. Please attach the following to help us reproduce this issue: 
-Detailed reproduction steps 
-Version information (Visual Studio → About Visual Studio menu) 
-Logs (Help → Open Log Directory, zip logs for the last 10 days) 
-Optional: project to reproduce your issue