Bug 6456 - MonoDevelop freezes on "Updating Xcode project for..."
Summary: MonoDevelop freezes on "Updating Xcode project for..."
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: iOS add-in ()
Version: unspecified
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: ---
Assignee: Jeffrey Stedfast
URL:
Depends on:
Blocks:
 
Reported: 2012-08-07 18:10 UTC by Dylan
Modified: 2013-04-03 14:42 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Crash report (284.41 KB, text/plain)
2012-08-07 18:11 UTC, Dylan
Details
~/Library/Logs/ (172.42 KB, application/octet-stream)
2012-08-07 18:46 UTC, Dylan
Details
problem-report-yvan-001 (402.41 KB, text/plain)
2012-09-15 10:09 UTC, Yvan Rodrigues
Details
In this case I pasted text into a new file, saved and closed that file, and the application froze. (428.24 KB, text/plain)
2012-09-16 18:55 UTC, Yvan Rodrigues
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Dylan 2012-08-07 18:10:46 UTC
Every 15-20 minutes after a few builds using latest MonoTouch stable (to simulator and phone) MonoDevelop freezes when it reaches the "Updating Xcode project for ..." stage. I then have to force quit upon such time the program crashes and creates a report to send to Apple. Do these crash reports reach you guys at all?

I then close Xcode before opening MonoDevelop again. When I next double click on a xib at this point two instances of Xcode opens up on the same project. I am assuming this is what causes MonoDevelop to break.
Comment 1 Dylan 2012-08-07 18:11:15 UTC
Created attachment 2322 [details]
Crash report
Comment 2 Dylan 2012-08-07 18:46:10 UTC
Created attachment 2323 [details]
~/Library/Logs/
Comment 3 Mikayla Hutchinson [MSFT] 2012-08-07 19:06:12 UTC
Unfortunately traces reported to Apple for non-appstore apps are not passed on to developers, and Apple's crash and hang traces do not contain useful stack information for Mono apps. 

If this happens again, could you please run the command "killall -QUIT MonoDevelop" in a terminal while MonoDevelop is hung but before Apple's hang reporter triggers? This will cause MonoDevelop to print full stack traces to its own log file. Please then attach MonoDevelop's logs from ~/Library/Logs/MonoDevelop-3.0.
Comment 4 Dylan 2012-08-07 19:07:31 UTC
Will do.
Comment 5 Yvan Rodrigues 2012-09-15 10:09:14 UTC
I don't know if it is the same issue but I have been getting freezes (and occasionally crashes) a few times a day. I can't say that it's the same issue as described here, but here is a Problem Report. From glancing over it, it looks like a race condition. 

Let me know if these are useful, and I'll send more.

[Attaching problem report]
Comment 6 Yvan Rodrigues 2012-09-15 10:09:56 UTC
Created attachment 2540 [details]
problem-report-yvan-001
Comment 7 Yvan Rodrigues 2012-09-16 18:55:51 UTC
Created attachment 2547 [details]
In this case I pasted text into a new file, saved and closed that file, and the application froze.
Comment 8 Jeffrey Stedfast 2013-04-02 17:10:10 UTC
is this still an issue for either of you guys?
Comment 9 Yvan Rodrigues 2013-04-02 17:12:40 UTC
Sorry, I haven't used it recently.
Comment 10 Jeffrey Stedfast 2013-04-02 17:17:06 UTC
no worries. if you use it again and this happens, let me know.
Comment 11 Dylan 2013-04-02 18:55:31 UTC
This doesn't seem to be an issue for me anymore on Xamarin Studio.
Comment 12 Jeffrey Stedfast 2013-04-03 14:42:12 UTC
ok, thanks