Bug 6440 - mcs-docs fails to build on ppc
Summary: mcs-docs fails to build on ppc
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Runtime
Classification: Mono
Component: Tools ()
Version: unspecified
Hardware: Other Linux
: --- normal
Target Milestone: ---
Assignee: Zoltan Varga
URL:
Depends on:
Blocks:
 
Reported: 2012-08-07 08:41 UTC by Dinar Valeev
Modified: 2017-07-12 23:55 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Dinar Valeev 2012-08-07 08:41:25 UTC
[ 2645s] make[7]: Entering directory
`/home/abuild/rpmbuild/BUILD/mono-2.10.6/mcs/docs'
[ 2645s] MDOC    [net_4_0] cs-errors.tree
[ 2650s] * Assertion at mini-exceptions.c:1856, condition `(guint8*)&sa >=
(guint8*)tls->stack_ovf_guard_base + tls->stack_ovf_guard_size' not met
[ 2650s]
[ 2650s] Stacktrace:
[ 2650s]
[ 2650s]
[ 2651s] Native stacktrace:
[ 2651s]
[ 2651s]   /home/abuild/rpmbuild/BUILD/mono-2.10.6/mono/mini/mono()
[0x100a2cac]
[ 2651s]  linux-vdso32.so.1(__kernel_sigtramp_rt32+0) [0x1003a0]
[ 2651s]         [0xf69af480]
[ 2651s]   /lib/libc.so.6(abort+0x248) [0xfd1a58c]
[ 2651s]        /home/abuild/rpmbuild/BUILD/mono-2.10.6/mono/mini/mono()
[0x101f6a58]
[ 2651s]  /home/abuild/rpmbuild/BUILD/mono-2.10.6/mono/mini/mono() [0x101f6b94]
[ 2651s]  /home/abuild/rpmbuild/BUILD/mono-2.10.6/mono/mini/mono() [0x100a2824]
[ 2651s]  /home/abuild/rpmbuild/BUILD/mono-2.10.6/mono/mini/mono() [0x10018024]
[ 2651s]  /home/abuild/rpmbuild/BUILD/mono-2.10.6/mono/mini/mono() [0x10018084]
[ 2651s]  /home/abuild/rpmbuild/BUILD/mono-2.10.6/mono/mini/mono() [0x1011f044]
[ 2651s]  /home/abuild/rpmbuild/BUILD/mono-2.10.6/mono/mini/mono() [0x101c6644]
[ 2651s]  /home/abuild/rpmbuild/BUILD/mono-2.10.6/mono/mini/mono() [0x102030e0]
[ 2651s]  /lib/libpthread.so.0(+0x7a80) [0xfe97a80]
[ 2651s]      /lib/libc.so.6(clone+0x84) [0xfdc92b8]
[ 2651s]
[ 2651s] Debug info from gdb:
[ 2651s]
[ 2651s]
[ 2651s] =================================================================
[ 2651s] Got a SIGABRT while executing native code. This usually indicates
[ 2651s] a fatal error in the mono runtime or one of the native libraries
[ 2651s] used by your application.
[ 2651s] =================================================================
[ 2651s]
[ 2651s] /bin/sh: line 1:  1715 Aborted                
MONO_PATH="./../class/lib/net_4_0:./../class/lib/net_2_0:$MONO_PATH"
/home/abuild/rpmbuild/BUILD/mono-2.10.6/runtime/mono-wrapper
./../tools/mdoc/mdoc.exe assemble -o cs-errors -f error cs-errors.config
[ 2651s] make[7]: *** [cs-errors.tree] Error 134
[ 2651s] make[7]: Leaving directory
`/home/abuild/rpmbuild/BUILD/mono-2.10.6/mcs/docs'
[ 2651s] make[6]: *** [do-all] Error 2
Comment 1 Miguel de Icaza [MSFT] 2012-09-02 12:54:43 UTC
Can you try Mono 2.11.3?
Comment 2 Dinar Valeev 2012-10-04 05:36:01 UTC
is there a tarball? I can't find it
Comment 3 Dinar Valeev 2012-10-04 05:52:46 UTC
Tried 2.11.5

Result is the same:
make[7]: Entering directory `/home/abuild/rpmbuild/BUILD/mono-2.11.5/mcs/docs'
MDOC    [net_4_5] cs-errors.tree
MDOC    [net_4_5] ecma334.tree
MDOC    [net_4_5] Mono.tree
MDOC    [net_4_5] netdocs.tree
MDOC    [net_4_5] Novell.tree
* Assertion at mini-exceptions.c:1938, condition `(guint8*)&sa >= (guint8*)tls->stack_ovf_guard_base + tls->stack_ovf_guard_size' not met

Stacktrace:


Native stacktrace:

	/home/abuild/rpmbuild/BUILD/mono-2.11.5/mono/mini/mono() [0x100ab6cc]
	linux-vdso32.so.1(__kernel_sigtramp_rt32+0) [0x1003a0]
	[0xeed1f480]
	/lib/libc.so.6(abort+0x248) [0xfd1a58c]
	/home/abuild/rpmbuild/BUILD/mono-2.11.5/mono/mini/mono() [0x102214f8]
	/home/abuild/rpmbuild/BUILD/mono-2.11.5/mono/mini/mono() [0x10221644]
	/home/abuild/rpmbuild/BUILD/mono-2.11.5/mono/mini/mono() [0x100ab264]
	/home/abuild/rpmbuild/BUILD/mono-2.11.5/mono/mini/mono() [0x100190bc]
	/home/abuild/rpmbuild/BUILD/mono-2.11.5/mono/mini/mono() [0x10019114]
	/home/abuild/rpmbuild/BUILD/mono-2.11.5/mono/mini/mono() [0x101b1d60]
	/home/abuild/rpmbuild/BUILD/mono-2.11.5/mono/mini/mono() [0x101f2bac]
	/home/abuild/rpmbuild/BUILD/mono-2.11.5/mono/mini/mono() [0x1020576c]
	/home/abuild/rpmbuild/BUILD/mono-2.11.5/mono/mini/mono() [0x10218100]
	/lib/libpthread.so.0(+0x7a80) [0xfe97a80]
	/lib/libc.so.6(clone+0x84) [0xfdc92b8]

Debug info from gdb:


=================================================================
Got a SIGABRT while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries 
used by your application.
=================================================================

/bin/sh: line 1: 31168 Aborted                 (core dumped) MONO_PATH="./../class/lib/net_4_5:./../class/lib/net_2_0:$MONO_PATH" /home/abuild/rpmbuild/BUILD/mono-2.11.5/runtime/mono-wrapper ./../class/lib/net_4_5/mdoc.exe assemble -o cs-errors -f error cs-errors.config
make[7]: *** [cs-errors.tree] Error 134
Comment 4 Zoltan Varga 2012-10-04 13:25:49 UTC
I don't have access to a ppc machine any more.
Comment 5 Dinar Valeev 2012-10-04 17:45:24 UTC
you can try qemu-user-ppc. Or just instruct me, how I can provide more useful information.

This is actually blocking us to build another packages like mono-tools (monodoc.xml is not available) or xsp
Comment 6 Zoltan Varga 2012-10-05 00:55:17 UTC
Is this ppc or ppc64 ?
Comment 7 Dinar Valeev 2012-10-05 04:46:21 UTC
This is ppc (32bit). ppc64 doesn't have this problem
Comment 8 Zoltan Varga 2012-10-05 06:40:33 UTC
As a workaround, try running mono configure with:
--with-sigaltstack=no
Comment 9 Dinar Valeev 2012-10-05 07:58:29 UTC
Yes, with that workaround 2.10.6 builds. 

Gives this any hint for you?
Comment 10 Zoltan Varga 2012-10-05 08:20:27 UTC
No, but at least there is a workaround now.
Comment 11 Rodrigo Kumpera 2017-07-12 23:55:25 UTC
Mono on ppc received a lot of fixes in the past 5 years, if this still happens with 5.2, please reopen.