Bug 6421 - mcs emits error CS0411 when csc and gmcs do not
Summary: mcs emits error CS0411 when csc and gmcs do not
Status: RESOLVED FIXED
Alias: None
Product: Compilers
Classification: Mono
Component: C# ()
Version: unspecified
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Marek Safar
URL:
Depends on:
Blocks:
 
Reported: 2012-08-06 12:03 UTC by Martin Potter
Modified: 2012-08-07 11:48 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Sample program that compiles fine with gmcs but not mcs (1.19 KB, application/octet-stream)
2012-08-06 12:03 UTC, Martin Potter
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Martin Potter 2012-08-06 12:03:31 UTC
Created attachment 2309 [details]
Sample program that compiles fine with gmcs but not mcs

When upgrading to Mono 2.11 and using mcs instead of gmcs, I encountered a bug where mcs emits error CS0411 when gmcs and csc do not. To reproduce, try to compile the attached program.

Expected results:
The program compiles without errors

Actual results:
CompilerBug.cs(41,32): error CS0411: The type arguments for method `CompilerBug.EventInfoUtility.DoFoo<TSource,TTarget>(this CompilerBug.EventInfo<TSource,System.EventHandler>, TSource, TTarget, System.Action<TTarget,object,System.EventArgs>)' cannot be inferred from the usage. Try specifying the type arguments explicitly
Comment 1 Marek Safar 2012-08-07 10:10:44 UTC
Fixed in master
Comment 2 Martin Potter 2012-08-07 11:48:14 UTC
Thank you for the quick fix on this bug.