Bug 6413 - System.Net.NetworkInformation.GetAllNetworkInterfaces() Fails when Personal Hotspot is Active
Summary: System.Net.NetworkInformation.GetAllNetworkInterfaces() Fails when Personal H...
Status: RESOLVED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: Xamarin.iOS.dll ()
Version: 5.99.x
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
: 7329 ()
Depends on:
Blocks:
 
Reported: 2012-08-06 08:30 UTC by Stuart Campbell
Modified: 2012-09-21 05:08 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Stuart Campbell 2012-08-06 08:30:46 UTC
I have confirmed this with two separate projects.

Call to System.Net.NetworkInformation.GetAllNetworkInterfaces() works fine under normal conditions. Turn on Personal Hotspot and the call fails 

System.ArgumentException: length
  at System.Array.Copy (System.Array sourceArray, Int32 sourceIndex, System.Array destinationArray, Int32 destinationIndex, Int32 length) [0x0020f] in /Developer/MonoTouch/Source/mono/mcs/class/corlib/System/Array.cs:1011
  at System.Net.NetworkInformation.MacOsNetworkInterface.ImplGetAllNetworkInterfaces () [0x00148] in /Developer/MonoTouch/Source/mono/mcs/class/System/System.Net.NetworkInformation/NetworkInterface.cs:472
  at System.Net.NetworkInformation.NetworkInterface.GetAllNetworkInterfaces () [0x00014] in /Developer/MonoTouch/Source/mono/mcs/class/System/System.Net.NetworkInformation/NetworkInterface.cs:58
Comment 1 Calin Turcu 2012-09-07 09:20:24 UTC
I can confirm this bug. Just upgraded MonoTouch to 5.4.0 and it's very annoying.
Comment 2 Rolf Bjarne Kvinge [MSFT] 2012-09-20 09:14:48 UTC
*** Bug 7329 has been marked as a duplicate of this bug. ***
Comment 3 Rolf Bjarne Kvinge [MSFT] 2012-09-20 20:13:13 UTC
Fixed. The next release (6.0.1) will include this fix.

master: a6921103b7ed7ae212debbf209921874db05969e
ios6: 1414645e5cded70d5ee51fb5968c50c97abfb34d
Comment 4 Rolf Bjarne Kvinge [MSFT] 2012-09-21 05:08:50 UTC
Correction:

master: ec5d2108a4296dd4e60ceebc65a55afcdb14bc88.