Bug 6389 - Absolute paths to project files cause error "MSBUILD0001: Unknown switch"
Summary: Absolute paths to project files cause error "MSBUILD0001: Unknown switch"
Status: NEW
Alias: None
Product: Tools
Classification: Mono
Component: xbuild ()
Version: unspecified
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-08-04 11:30 UTC by Ian Battersby
Modified: 2012-08-07 16:39 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 6389 on GitHub or Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: GitHub Markdown or Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
NEW

Description Ian Battersby 2012-08-04 11:30:33 UTC
Mono version:-
2.11.2

xbuild version:-
2.11.2.0

OS:-
Mountain Lion (Darwin 10.8)

Issue:-
When calling xbuild with absolute paths to project files it gives you an "MSBUILD0001: Unknown switch" error. Doing the same with a relative path works fine. For example;

xbuild "/Users/ian/Code/Simple.Web/Sandbox/Sandbox.csproj" /t:Build /p:OutputPath="Users/ian/Code/Simple.Web/build" /p:Configuration="Debug" /p:VSToolsPath="/Library/Frameworks/Mono.framework/Libraries/mono/xbuild/Microsoft/VisualStudio/v9.0"
MSBUILD: error MSBUILD0001: Unknown switch: /Users/ian/Code/Simple.Web/Sandbox/Sandbox.csproj

.. this works ..

build "./Sandbox/Sandbox.csproj" /t:Build /p:OutputPath="Users/ian/Code/Simple.Web/build" /p:Configuration="Debug" /p:VSToolsPath="/Library/Frameworks/Mono.framework/Libraries/mono/xbuild/Microsoft/VisualStudio/v9.0"

Source code form example found at:-
https://github.com/ianbattersby/Simple.Web/tree/MonoCompat
Comment 1 Ian Battersby 2012-08-05 18:12:40 UTC
FYI;

Reading the source history it seems others have noticed this to:
https://github.com/mono/mono/commit/667eb08736701f413d42d4362875702114b5a760#mcs/tools/xbuild/Parameters.cs
Comment 2 Ian Battersby 2012-08-07 16:39:44 UTC
FYI; 

Have submitted pull-request: https://github.com/mono/mono/pull/422