Bug 6298 - Cannot click 'Restart and Install Updates'
Summary: Cannot click 'Restart and Install Updates'
Status: RESOLVED DUPLICATE of bug 6299
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Updater ()
Version: unspecified
Hardware: PC Mac OS
: Highest blocker
Target Milestone: ---
Assignee: Duncan Mak
URL:
Depends on:
Blocks:
 
Reported: 2012-07-26 11:11 UTC by Alan McGovern
Modified: 2012-07-26 13:18 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 6299

Description Alan McGovern 2012-07-26 11:11:10 UTC
This button is greyed out and cannot be clicked. There's no way for me to install the freshly downloaded updates.

I am currently being told that MonoDevelop 3.0.4 is downloaded and ready to install and MonoTouch 5.3.5 has failed to download. Maybe this failure is preventing the installation from happening.
Comment 1 Miguel de Icaza [MSFT] 2012-07-26 11:14:18 UTC
Getting the same problem.

Also the 5.3.5 update is failing to download, wonder why.
Comment 2 Sebastien Pouliot 2012-07-26 11:18:50 UTC
Download "worked" (as did not report any error) but I get into a loop of "Error: Failed to attach disk image" and MD restaring (over and over again) trying to update to MD 3.0.4 alpha.

Maybe the file(s) or state are corrupt ?
Comment 3 Alan McGovern 2012-07-26 11:28:28 UTC
The issue appears to be that the contents of his index.xml is:

https://gist.github.com/d0073e7b9d537d635897

The important part is that it's listing the MonoDevelop update as having <Status>Downloaded</Status>, however there are no dmgs in ~/Library/Caches/MonoDevelop-3.0/TempDownload
Comment 4 Alan McGovern 2012-07-26 11:29:18 UTC
Ah, spouliots is is: https://bugzilla.xamarin.com/show_bug.cgi?id=6054

The issue reported in the first comment is still there though.
Comment 5 Miguel de Icaza [MSFT] 2012-07-26 11:49:36 UTC
On Mac, having the same issue with the DMG not being attached, MD restarting, and aborting the install of anything after MD:

mono$ md5 /Users/miguel/Library/Caches/MonoDevelop-3.0/TempDownload/*dmg
MD5 (/Users/miguel/Library/Caches/MonoDevelop-3.0/TempDownload/4569c276-1397-4adb-9485-82a7696df22e.dmg) = cdfb7debdb79ac474f3fdeb60b03b532
MD5 (/Users/miguel/Library/Caches/MonoDevelop-3.0/TempDownload/d1ec039f-f3db-468b-a508-896d7c382999.dmg) = 01590480ef0c638161476b48c31cb562

The above is trying to update to MD 3.0.4 and MT 5.3.5
Comment 6 Mikayla Hutchinson [MSFT] 2012-07-26 13:18:08 UTC
Correct, you cannot install until all the updates downloaded.

*** This bug has been marked as a duplicate of bug 6299 ***