Bug 6232 - MonoDevelop and MonoDevelop installer doesn't adhere to proxy settings on Mac OS X
Summary: MonoDevelop and MonoDevelop installer doesn't adhere to proxy settings on Mac...
Status: RESOLVED DUPLICATE of bug 1606
Alias: None
Product: iOS
Classification: Xamarin
Component: General ()
Version: 5.3.x
Hardware: PC Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-07-23 05:13 UTC by Magnus Johansson
Modified: 2012-07-23 14:53 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 1606

Description Magnus Johansson 2012-07-23 05:13:28 UTC
Hi there.

Mac OS X 10.7.5.

I connect my Mac through a corporate firewall and proxy, so I have a proxy defined in the Network Settings in System Preferences.
All applications (that I have used so far at least) adhere to this setting, FireFox, Chrome, Eclipse etc., but MonoDevelop does not, so I can't update. Even worse, the new web based installer doesn't either adhere to the proxy settings, so I can't now download manually either.

So now I'm stuck. How can I download your products?

Please make sure that your product follow the System Network proxy settings.

Regards,
Magnus


Here's what the installer tells me:

Error downloading from MonoTouch server. MonoTouch.
The request timed out
Exception type: System.Net.WebException
Message: The request timed out
at System.Net.HttpWebRequest.EndGetResponse (IAsyncResult asyncResult) [0x00000] in <filename unknown>:0
at System.Net.HttpWebRequest.GetResponse () [0x00000] in <filename unknown>:0
at Xamarin.Web.Installer.Utilities.DownloadUrl (System.String url, System.Action`4 doDownload, System.Func`3 webExceptionHandler, Boolean noCache, System.Object state) [0x00000] in <filename unknown>:0

MonoTouch installation failed with more than one exception (Attempt #MonoTouch)
Some installation errors are present.
Exception type: System.AggregateException
Message: Some installation errors are present.
Exception type: Xamarin.Web.Installer.InstallException
Message: Download failed.
at Xamarin.Web.Installer.Installer.BaseSoftwareItem.ValidateDownloadItem () [0x00000] in <filename unknown>:0
at Xamarin.Web.Installer.Installer.BaseSoftwareItem.Install (UInt32 tryNumber) [0x00000] in <filename unknown>:0
at MacInstaller.WizardPageInstallationController.InstallationWorker () [0x00000] in <filename unknown>:0
Exception type: System.Net.WebException
Message: The request timed out
at System.Net.HttpWebRequest.EndGetResponse (IAsyncResult asyncResult) [0x00000] in <filename unknown>:0
at System.Net.HttpWebRequest.GetResponse () [0x00000] in <filename unknown>:0
at Xamarin.Web.Installer.Utilities.DownloadUrl (System.String url, System.Action`4 doDownload, System.Func`3 webExceptionHandler, Boolean noCache, System.Object state) [0x00000] in <filename unknown>:0
Exception type: Xamarin.Web.Installer.InstallException
Message: Download failed.
at Xamarin.Web.Installer.Installer.BaseSoftwareItem.ValidateDownloadItem () [0x00000] in <filename unknown>:0
at Xamarin.Web.Installer.Installer.BaseSoftwareItem.Install (UInt32 tryNumber) [0x00000] in <filename unknown>:0
at MacInstaller.WizardPageInstallationController.InstallationWorker () [0x00000] in <filename unknown>:0
Exception type: System.Net.WebException
Message: The request timed out
at System.Net.HttpWebRequest.EndGetResponse (IAsyncResult asyncResult) [0x00000] in <filename unknown>:0
at System.Net.HttpWebRequest.GetResponse () [0x00000] in <filename unknown>:0
at Xamarin.Web.Installer.Utilities.DownloadUrl (System.String url, System.Action`4 doDownload, System.Func`3 webExceptionHandler, Boolean noCache, System.Object state) [0x00000] in <filename unknown>:0
Exception type: Xamarin.Web.Installer.InstallException
Message: Download failed.
at Xamarin.Web.Installer.Installer.BaseSoftwareItem.ValidateDownloadItem () [0x00000] in <filename unknown>:0
at Xamarin.Web.Installer.Installer.BaseSoftwareItem.Install (UInt32 tryNumber) [0x00000] in <filename unknown>:0
at MacInstaller.WizardPageInstallationController.InstallationWorker () [0x00000] in <filename unknown>:0
Exception type: System.Net.WebException
Message: The request timed out
at System.Net.HttpWebRequest.EndGetResponse (IAsyncResult asyncResult) [0x00000] in <filename unknown>:0
at System.Net.HttpWebRequest.GetResponse () [0x00000] in <filename unknown>:0
at Xamarin.Web.Installer.Utilities.DownloadUrl (System.String url, System.Action`4 doDownload, System.Func`3 webExceptionHandler, Boolean noCache, System.Object state) [0x00000] in <filename unknown>:0
Comment 1 Rolf Bjarne Kvinge [MSFT] 2012-07-23 06:13:06 UTC
Marek, this looks like your area.
Comment 2 Mikayla Hutchinson [MSFT] 2012-07-23 14:53:34 UTC

*** This bug has been marked as a duplicate of bug 1606 ***