Bug 614 - Not Able to open MonoDevelop anymore
Summary: Not Able to open MonoDevelop anymore
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: 2.4.2
Hardware: Macintosh Mac OS
: High normal
Target Milestone: ---
Assignee: Alex Corrado [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2011-09-03 06:50 UTC by Lorenzo
Modified: 2011-12-29 03:41 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Lorenzo 2011-09-03 06:50:22 UTC
When I try to open MonoDevelop this error appears in the console log

    com.apple.launchd.peruser.501[249] ([0x0-0x13013].com.ximian.monodevelop[308]) Exited with exit code: 255


This is the error if I try to run MonoDevelop from command shell

    LSOpenURLsWithRole() failed with error -10810 for the file /Applications/MonoDevelop.app.

This is my configuration: Snow Leopard 10.6.8, MonoDevelop 2.4.2, Mono 2.10.5 and MT 4.0.7.

Any help is appreciated. Regards.
Comment 1 Lorenzo 2011-09-03 09:09:44 UTC
This is the MonoDevelop crash reporter log:

FATAL ERROR [2011-09-03 15:06:25Z]: MonoDevelop failed to start. Some of the assemblies required to run MonoDevelop (for example gtk-sharp, gnome-sharp or gtkhtml-sharp) may not be properly installed in the GAC.
System.DllNotFoundException: /Library/Frameworks/Mono.framework/Versions/2.10.5/lib/libgtk-quartz-2.0.0.dylib
  at (wrapper managed-to-native) Gtk.Application:gtk_init (int&,intptr&)
  at Gtk.Application.do_init (System.String progname, System.String[]& args, Boolean check) [0x00000] in <filename unknown>:0 
  at Gtk.Application.Init (System.String progname, System.String[]& args) [0x00000] in <filename unknown>:0 
  at MonoDevelop.Ide.IdeStartup.Run (System.String[] args) [0x00000] in <filename unknown>:0 
  at MonoDevelop.Startup.MonoDevelopMain.Main (System.String[] args) [0x00000] in <filename unknown>:0
Comment 2 Lorenzo 2011-09-03 11:11:39 UTC
I've fixed the problem uninstalling Mono Framework 2.10.5 and installing 2.10.4.

For further information:

I've run the uninstall script that I've found in Mono documentation.
I can't understand if the error is due to 2.10.5 version or not.

Regards.
Comment 3 Mikayla Hutchinson [MSFT] 2011-09-03 12:56:31 UTC
This sounds like a packaging bug in 2.10.5 then.
Comment 4 Lorenzo 2011-09-04 07:03:35 UTC
Thank you for your reply.

Regards, Lorenzo.
Comment 5 Lorenzo 2011-09-24 09:44:21 UTC
Does 2.10.5 packaging bug have been fixed?
I've tried again but MonoDevelop doesn't start.

The error is always the same:

System.DllNotFoundException:
/Library/Frameworks/Mono.framework/Versions/2.10.5/lib/libgtk-quartz-2.0.0.dylib

Version 2.10.4 works.

Thank you in advance.
Comment 6 Mikayla Hutchinson [MSFT] 2011-10-07 08:26:53 UTC
Can you try Mono 2.10.6?
Comment 7 Lorenzo 2011-10-07 08:32:30 UTC
Thank you for your reply.

Where can I find Mono 2.10.6?

Reagards.
Comment 8 Mikayla Hutchinson [MSFT] 2011-10-07 08:55:58 UTC
I'm not sure why it hasn't been published yet - it's on the server.

http://origin-download.mono-project.com/archive/2.10.6/macos-10-x86/1/MonoFramework-MDK-2.10.6_1.macos10.xamarin.x86.dmg
Comment 9 Lorenzo 2011-10-16 09:57:38 UTC
Dear Michael,

I've just installed 2.10.6 and it works. MonoDevelop now opens correctly.
Thank you for your support.

Regards, Lorenzo.
Comment 10 Atin 2011-12-29 02:39:46 UTC
We have validated this issue and don't get any error while launching MD.

Please close this issue.

Environments:
MAC 10.7
Mono Develop 2.8.5 Stable.
Mono Touch 5.0.4 Stable
Mono Framework 2.0.7 Beta
Comment 11 Atin 2011-12-29 03:41:47 UTC
We have validated this issue and don't get any error while launching Mono Develop .
Please close this issue.

Environments:
MAC 10.7
Mono Develop 2.8.5 Stable.
Mono Touch 5.0.4 Stable
Mono Framework 2.0.7 Beta