Bug 6127 - Find implementor classes shows attribute instead of class name
Summary: Find implementor classes shows attribute instead of class name
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: C# Binding ()
Version: Trunk
Hardware: PC Linux
: Normal normal
Target Milestone: ---
Assignee: Mike Krüger
URL:
Depends on:
Blocks:
 
Reported: 2012-07-15 10:32 UTC by Andres G. Aragoneses
Modified: 2012-07-16 06:41 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Andres G. Aragoneses 2012-07-15 10:32:45 UTC
Steps to reproduce:
1. Clone monodevelop master.
2. Run it.
3. Open Main.sln of MonoDevelop itself.
4. Go to the file that has the type "ITypeReference".
5. Right click on it -> Find implementor classes.

Expected results:
All classes that implement the interface are shown.

Current results:
Some classes are shown. But some of the lines of the result don't show the class name but the attribute [Serializable].
Comment 1 Mike Krüger 2012-07-16 06:41:09 UTC
fixed.