Bug 61238 - "Xamarin Profiler" missing from menus
Summary: "Xamarin Profiler" missing from menus
Status: NEW
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Profiler Integration ()
Version: unspecified
Hardware: PC Windows
: High major
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2018-02-26 05:36 UTC by Kym Phillpotts
Modified: 2018-03-09 03:27 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
VS version info & Xamarin log (4.70 KB, application/x-zip-compressed)
2018-03-02 01:40 UTC, Jesse
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 61238 on Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.
Related Links:
Status:
NEW

Description Kym Phillpotts 2018-02-26 05:36:33 UTC
On Visual Studio 2017 Enterprise PC unable to get the profiler to appear in the menus.

There are multiple people in the forums talking about the same issue:
 * https://forums.xamarin.com/discussion/122451/visual-studio-2017-enterprise-xamarin-profiler-is-not-showing
 * https://forums.xamarin.com/discussion/122009/visual-studio-2017-wont-display-xamarin-profiler-spent-5-hours
 * https://forums.xamarin.com/discussion/122276/xamarin-profiler-not-showing-in-vs2017-enterprise

Here is a gist to my VS Info: https://gist.github.com/kphillpotts/ea18098ac99f9ae05db0f5c53e048453

Also have tried reinstalling multiple times, but no luck.
Comment 1 Jesse 2018-03-02 01:40:52 UTC
Created attachment 26198 [details]
VS version info & Xamarin log

A user reported the same issue early February.  Neither reinstalling the extension nor reinstalling VS resolved it. 

Attached are VS's version information (including extensions) and the most recent Xamarin (IDE) log that shows the issue.

VS recognizes the user's account as an Enterprise account, as shown in the Xamarin logs.
Comment 4 Brendan Zagaeski (Xamarin Team, assistant) 2018-03-09 03:27:07 UTC
As a notice to anyone who is looking at this thread--

The user who originally reported the issue was able to resolve it (and use Xamarin Profiler without problems) by updating to Visual Studio 2017 version 15.6 (and on Mac, Visual Studio 2017 for Mac version 7.4).