Bug 61213 - Android phone "Google Pixel 2" doesn't show up in list "to Run on" in VS2017
Summary: Android phone "Google Pixel 2" doesn't show up in list "to Run on" in VS2017
Status: RESOLVED FIXED
Alias: None
Product: Live Player
Classification: Xamarin
Component: IDE Extension ()
Version: 1.5.X
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2018-02-09 18:49 UTC by Jakub Suchy
Modified: 2018-03-05 16:00 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Jakub Suchy 2018-02-09 18:49:29 UTC
Description:
Given VS2017 and android phone "Google Pixel 2"
When I try to run on target "Live Player" and I pair it successfully
Then "Google Pixel 2" doesn't show up in the list of targets to run on

I tried pairing my LG Nexus 5 and it successfully paired and it showed up in the list of targets to run on. So it is working, however not for Google Pixel 2.

Repro steps:
1. Create blank Xamarin.Forms App with all platforms (Android, iOS, UWP)
2. Unload iOS and UWP projects
3. Select target "Live Player"
4. Pair the Google Pixel 2
5. Verify that Pairing was successfull in the window on PC (Google Pixel 2 is in the list next to the QR core for pairing)
6. Verify that on phone there is "Connected to Visual Studio"
7. Verify that in the list of targets to run on, there is no "Google Pixel 2"

Ad 5. https://i.imgur.com/XoB0kPJ.png
Ad 6. https://i.imgur.com/y07ehpB.png
Ad 7. https://i.imgur.com/QITKDAR.png

Devices and IDE states:
VS2017 version 15.5.6
VS2017 Android SDK Manager downloaded API levels 27,26,25,24,23 (Android SDK Platform + Sources for Android)
Windows 10 version 16299.214
Google Pixel 2 Android version 8.1.0
Xamarin Live Player version 1.5.176
Xamarin Live Player Connection Test "Everything looks good, wifi on, server reachable"
Comment 1 James Montemagno [MSFT] 2018-03-05 16:00:22 UTC
https://forums.xamarin.com/discussion/113879/android-8-1-not-showing-in-debug-list-workaround#latest

Fixed in 15.6, workaround listed here.