Bug 6116 - imports lost in XCode when using MapView
Summary: imports lost in XCode when using MapView
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: iOS add-in ()
Version: unspecified
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Jeffrey Stedfast
URL:
Depends on:
Blocks:
 
Reported: 2012-07-13 15:11 UTC by Neal
Modified: 2012-07-17 15:21 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Neal 2012-07-13 15:11:56 UTC
Hello,

I watched Mike's Seminar yesterday which got me interested in learning MapKit.  I added a MapView to a new XIB and noticed I needed to add the @import <MapView/MapView.h> (or whatever it is).  When I come back to the XIB later to adjust the UI the #import is not preserved, it's missing and needs to be readded to clear the errors in Xcode.  I created an Outlet for the mapView.

FYI
Comment 1 Jeffrey Stedfast 2012-07-17 15:21:51 UTC
None of the headers are preserved, actually, it just #import's a static list of headers.

I've added MapKit/MapKit.h to that list.