Bug 61097 - Second build is not successful(can't find resources from common ui project)
Summary: Second build is not successful(can't find resources from common ui project)
Status: NEEDINFO
Alias: None
Product: Android
Classification: Xamarin
Component: MSBuild ()
Version: 8.2 (15.6)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: dean.ellis
URL:
Depends on:
Blocks:
 
Reported: 2017-12-14 12:08 UTC by neuronkarrde@gmail.com
Modified: 2017-12-14 17:06 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 61097 on Developer Community or GitHub if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
NEEDINFO

Description neuronkarrde@gmail.com 2017-12-14 12:08:53 UTC
Have solution with 2 android projects: executable and common.droid lib
Faced with strange issue:
1)First build is successful
2)No any changes in code. Second build causes errors, app doesn't see several resources(attributes) from common.droid
3)After that you can successfully build app only after clean solution

After a small investigation found a workound: delete common.droid/obj/Debug/build.props file solve this problem, all obj files generated correctly, build is successful
Comment 1 Jon Douglas [MSFT] 2017-12-14 17:06:34 UTC
(In reply to neuronkarrde@gmail.com from comment #0)
> Have solution with 2 android projects: executable and common.droid lib
> Faced with strange issue:
> 1)First build is successful
> 2)No any changes in code. Second build causes errors, app doesn't see
> several resources(attributes) from common.droid
> 3)After that you can successfully build app only after clean solution
> 
> After a small investigation found a workound: delete
> common.droid/obj/Debug/build.props file solve this problem, all obj files
> generated correctly, build is successful

Thank you for the report, if it's possible, please take a few minutes to look through our best practices when filing a bug to include the minimum information to help us address your report!

https://developer.xamarin.com/guides/cross-platform/troubleshooting/questions/howto-file-bug/#Best_practices_to_help_Xamarin_address_bugs_quickly_and_efficiently

Next steps for you:

1. Include respective Diagnostic Build Outputs from each build -
 https://developer.xamarin.com/guides/android/troubleshooting/troubleshooting/#Diagnostic_MSBuild_Output

2. Include a self-contained test case that demonstrates this behavior. You can attach it directly to the bug report, or include a link to a download.

3. Include your environment information such as your Visual Studio version, Xamarin Version, etc - https://developer.xamarin.com/guides/cross-platform/troubleshooting/questions/version-logs/