Bug 61043 - App crashes abruptly for uikit exception in debug mode
Summary: App crashes abruptly for uikit exception in debug mode
Status: RESOLVED NORESPONSE
Alias: None
Product: iOS
Classification: Xamarin
Component: Debugger ()
Version: XI 11.6 (xcode9.2)
Hardware: Other Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-12-08 10:41 UTC by Mahfuz
Modified: 2018-02-27 07:59 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description Mahfuz 2017-12-08 10:41:41 UTC
How to reproduce:
1. add some error logic in your uikit code, like poorly formatted constraint string, removing absent cells from tableview, etc.
2. deploy the app in debug mode to ios device or simulator.
3. goto the screen where error happens and see the app hungs and connection to the debugger lost abruptly.

if i launch the app without debugger connection, app crashes and then when i open it again, i get the error report sent to my hockeyapp logs.
Comment 1 Timothy Risi 2017-12-08 18:01:14 UTC
Please include your full build logs, crash reports (if any), test case (to reproduce) and all your version information.

To get full build logs just set the log verbosity to diagnostic at the following locations:
- On Visual Studio for Mac: Preferences > Projects > Build
- On Visual Studio for Windows: Tools > Options > Projects and Solutions > Build and Run

On Visual Studio Windows you also want to add `-v -v -v -v` to the mtouch additional arguments by right-clicking the project in the solution explorer and selecting `Properties`.
Note: this is done automatically on Visual Studio for Mac when the log verbosity is set to diagnostic.

The easiest way to get exact version information:
- On Visual Studio for Mac: "Visual Studio" menu, "About Visual Studio" item, "Show Details" button.
- On Visual Studio for Windows: "Help menu", "About Microsoft Visual Studio" item.
Then copy/paste the version information (you can use the "Copy Information" button).
Comment 2 Manuel de la Peña [MSFT] 2018-01-08 11:50:01 UTC
@Mahfuz can you please provide the requested information by @Tim as well was the test case?
Comment 3 Manuel de la Peña [MSFT] 2018-02-26 16:18:24 UTC
We have not received the requested information. If you are still experiencing this issue please provide all the requested information then click the Reopen Issue button. Thanks!