Bug 60973 - Weak fields PR introduced failing weak-fields.exe test on ARM
Summary: Weak fields PR introduced failing weak-fields.exe test on ARM
Status: RESOLVED ANSWERED
Alias: None
Product: Runtime
Classification: Mono
Component: General ()
Version: master
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-12-04 18:05 UTC by Alexander Köplinger [MSFT]
Modified: 2018-01-12 11:06 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED ANSWERED

Description Alexander Köplinger [MSFT] 2017-12-04 18:05:24 UTC
MonoTests.runtime.weak-fields.exe:

> Finalized. 0
> Finalized. 0
> Finalized. 0
> Finalized. 16946264

I'm disabling it for now.
Comment 1 Alexander Köplinger [MSFT] 2017-12-04 23:11:03 UTC
It fails on amd64 on FullAOT as well.
Comment 2 Marek Safar 2017-12-18 17:29:27 UTC
Zoltan, it this in the bucket of expected behaviour ?
Comment 3 Zoltan Varga 2017-12-19 16:53:11 UTC
The object that the weak field points to seems to be randomly retained, which causes the failure, don't think this is actually related to the weak field changes, the test seems to be faulty.
Comment 4 Ludovic Henry 2018-01-12 11:06:11 UTC
Moved to https://github.com/mono/mono/issues/6490