Bug 60917 - References In Project Not Resolving
Summary: References In Project Not Resolving
Status: RESOLVED INVALID
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Inspector Integration ()
Version: 4.7.0 (15.4)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: xamarininteractive
URL:
Depends on:
Blocks:
 
Reported: 2017-11-30 01:14 UTC by AMD
Modified: 2017-12-04 16:13 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Screenshot of Issue (33.73 KB, image/png)
2017-11-30 01:14 UTC, AMD
Details
Xamarin Zip Logs (22.81 KB, application/x-zip-compressed)
2017-11-30 01:15 UTC, AMD
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED INVALID

Description AMD 2017-11-30 01:14:44 UTC
Created attachment 25866 [details]
Screenshot of Issue

When opening any .cs file under the iOS project in Xamarin (using VS 15.4.5) none of the Xamarin references are resolving. However the project can build. This renders 1000s of errors in the UI as well as not being able to use intelli-sense.

For clarification: in a file called DialpadPage.xaml.cs the using statement for using Xamarin.Forms and Xamarin.Forms.Xaml is red (the "Xamarin" specifically is red) and then any Xamarin objects are Red on teh page, as well as anything defined in teh XAML.

For example see screenshot. This happens with EVERY page and viewmodel. In teh Viewmodel the System.ComponentModel is red as well.
Comment 1 AMD 2017-11-30 01:15:59 UTC
Created attachment 25867 [details]
Xamarin Zip Logs

See xamarin logs
Comment 2 AMD 2017-11-30 02:06:12 UTC
Sorry this is a bug in Resharper. Didn't realize that! please close/cancel the bug.