Bug 60895 - 15.4.5: Xamarin disconnecting from mac and fails to reconnect
Summary: 15.4.5: Xamarin disconnecting from mac and fails to reconnect
Status: RESOLVED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 4.7.0 (15.4)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-11-28 15:38 UTC by softlion
Modified: 2017-12-23 09:32 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description softlion 2017-11-28 15:38:52 UTC
I have a new issue since i updated to VS2017 15.4.5 (or maybe it is mac OS high sierra)

VS2017 connects fine to the mac for build and debugging on simulator.
After some time (10/15mn), it disconnects from the mac and is unable to reconnect.

The only workaround is to kill the Xamarin IDB process on the mac, then ask VS2017 to reconnect.
Restarting VS2017 alone does not help.
Comment 1 softlion 2017-11-28 15:45:06 UTC
Starting Agent Build 4.7.10.38...
Starting Agent IDB 4.7.10.38...
An error occured starting the Build 4.7.10.38 agent: The Build Agent initialization exceeded the timeout of 60000 millisecs without receiving confirmation from the Agent.
Comment 2 Jimmy [MSFT] 2017-12-20 21:35:55 UTC
I saw that you also commented on bug 60358. Are you still experiencing this issue with Xamarin 4.8.0.756 on Windows and the latest Xamarin.iOS on the Mac?
Comment 3 softlion 2017-12-23 09:32:54 UTC
No its working fine