Bug 60892 - Full path not used in mini/main.c for linux
Summary: Full path not used in mini/main.c for linux
Status: NEW
Alias: None
Product: Runtime
Classification: Mono
Component: General ()
Version: master
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-11-28 14:51 UTC by fredrik.marcus
Modified: 2017-11-28 14:51 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Suggest solution (816 bytes, patch)
2017-11-28 14:51 UTC, fredrik.marcus
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 60892 on GitHub or Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: GitHub Markdown or Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
NEW

Description fredrik.marcus 2017-11-28 14:51:26 UTC
Created attachment 25849 [details]
Suggest solution

Scenario:
Static linked application placed in folder ~/bin
~/bin added to path

When application is called mono it self responds to the command line not the application.


I found that argv[0] was used to located the application it self.
This does not work because argv[0] does not contain full path.

Suggested path is attached. See also comments in path.

Patch tested on Ubuntu 14.04