Bug 60796 - XAML is drawing on screen for Xamarin.Forms 2.5.0.91635
Summary: XAML is drawing on screen for Xamarin.Forms 2.5.0.91635
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Forms
Classification: Xamarin
Component: Android ()
Version: 2.5.0
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-11-22 07:37 UTC by Ahmad Raza
Modified: 2017-12-29 10:20 UTC (History)
5 users (show)

Tags: needs_repro
Is this bug a regression?: ---
Last known good build:


Attachments
UI screenshot. (19.66 KB, image/png)
2017-11-22 07:37 UTC, Ahmad Raza
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Ahmad Raza 2017-11-22 07:37:38 UTC
Created attachment 25787 [details]
UI screenshot.

I've upgraded my application to Xamarin.Forms new version 2.5.0.91635 and it stopped populating the XAML UI for Android. Everything works fine for iOS. But for Andorid, it only loads the parent container and nothing from its child.

CODE:
<ContentPage.Content>
        <AbsoluteLayout
            BackgroundColor="Aqua"
            HorizontalOptions="FillAndExpand"
            VerticalOptions="FillAndExpand">
            <StackLayout
                BackgroundColor="Fuchsia"
                Padding="12"
                AbsoluteLayout.LayoutFlags="PositionProportional"
                AbsoluteLayout.LayoutBounds="0.5,0.5,-1,-1">
                <ActivityIndicator
                    x:Name="activityIndicator"
                    StyleId="Login_actindicator"
                    HorizontalOptions="Center"
                    VerticalOptions="Center"
                    IsRunning="{Binding ShowActivityIndicator}"
                    IsVisible="{Binding ShowActivityIndicator}" />
            </StackLayout>
        </AbsoluteLayout>
    </ContentPage.Content>


UI(see attachments).
Comment 1 Paul DiPietro [MSFT] 2017-11-29 18:37:50 UTC
I am unable to reproduce this issue using the 2.5.0.91635 build on both an emulator and S8 device; the ActivityIndicator shows as expected. Please upload a minimized reproduction project that we can use to investigate the issue further, as well as information about the emulators and/or devices on which you experience the behavior in question. Making certain to delete all bin/obj/package folders along with cleaning the project will minimize its size for upload.
Comment 2 Paul DiPietro [MSFT] 2017-12-14 00:41:18 UTC
Closing as not reproducible until we receive a reproduction project. Please reopen this issue with one or alternatively file a new report on GitHub (https://github.com/xamarin/Xamarin.Forms/issues) if the issue still occurs.
Comment 3 Bon Macalindong 2017-12-29 10:20:58 UTC
When you upgraded you XF version,  did you also updated your Android Support Libraries to 25.4.0.2 or greater?