Bug 60752 - Bluetooth printers are no longer detected on iOS 11 devices
Summary: Bluetooth printers are no longer detected on iOS 11 devices
Status: RESOLVED UPSTREAM
Alias: None
Product: iOS
Classification: Xamarin
Component: General ()
Version: XI 11.3 (xcode9.1)
Hardware: Other Other
: --- normal
Target Milestone: Future Cycle (TBD)
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-11-18 19:30 UTC by nitemsg
Modified: 2017-11-20 14:30 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED UPSTREAM

Description nitemsg 2017-11-18 19:30:47 UTC
Up to iOS 10 bluetooth POS printers (Bixolon spp-r400, Bixolon spp-r410, Zebra zq520) are detected and working fine with XI 10.3 running on iPad.

On iOS 11 with XI 10.3 the printers are detected, but the connection is lost after a couple printing sessions. "Accessory for departure" message shows up in the console and EAAccessoryManager.SharedAccessoryManager.ConnectedAccessories returns an empty list after that.
Forget/unpair device and pair again is neccessary in order for the printers to be available again (in the ConnectedAccessories list)

On iOS 11 with XI 11.3/XCode9.1 the printers are never detected and EAAccessoryManager.SharedAccessoryManager.ConnectedAccessories returns always an empty list.



Visual Studio Enterprise 2017 for Mac
Version 7.2.2 (build 11)
Installation UUID: 0aa4687e-cd88-4713-a8ce-46866b31df87
Runtime:
	Mono 5.4.1.6 (2017-06/1f4613aa1ac) (64-bit)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 504010006

Apple Developer Tools
Xcode 9.1 (13532)
Build 9B55

Xamarin.iOS
Version: 11.3.0.47 (Visual Studio Enterprise)
Hash: 51128b8c
Branch: xcode9.1
Build date: 2017-10-31 22:42:13-0400
Comment 1 nitemsg 2017-11-18 19:38:42 UTC
With "detected" I'm not referring to the iOS. iOS always detects and pairs the devices correctly. I'm referring to the application and specifically to
EAAccessoryManager.SharedAccessoryManager.ConnectedAccessories
Comment 2 Alex Soto [MSFT] 2017-11-20 14:30:42 UTC
Unfortunately, you are not alone having printing issues, a quick google search shows lots of complaints about it, for example, https://developer.zebra.com/thread/34879 so this is not really an issue with Xamarin.iOS, you would have the same connection issues if your app was using ObjC or swift.

Xamarin.iOS is just a thin layer to interop with CocoaTouch frameworks[1] using C# so in this case you are getting an empty array because that is what the native EA framework returned.

I would suggest updating one of your devices to the current iOS beta to see if it fixed there if not, open a radar[2] with Apple.

[1]:https://github.com/xamarin/xamarin-macios/blob/aca0e2ed2e019ded169eadae6949307a7ab663b7/src/externalaccessory.cs#L94-L95
[2]: https://developer.apple.com/bug-reporting/