Bug 60643 - InitalizeComponent parse error
Summary: InitalizeComponent parse error
Status: NEW
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: General ()
Version: 4.8.0 (15.5)
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-11-13 12:55 UTC by antoniocaroppos
Modified: 2017-11-13 12:58 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 60643 on Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.
Related Links:
Status:
NEW

Description antoniocaroppos 2017-11-13 12:55:26 UTC
I always get the following 3 errors:

Error CA0001 CA0001 : Error while parsing von IL after method: 'MyApp.CellEditor.InitializeComponent', Command at Offset '0x18F' with Opcode 'Callvirt'.

Error CA0001 CA0001 : Member "get_Assembly" wurde in Typ "System.Type" in Assembly "MyApp, Version=1.0.6526.24471, Culture=neutral" not found.

Error CA0001 CA0001 : Rule=Microsoft.Usage#CA2214, Target=MyApp.CellEditor.#.ctor() : Error while parsing von IL after method: 'MyApp.CellEditor.InitializeComponent', Command at Offset '0x18F' with Opcode 'Callvirt'.

I don't know what I do to make these errors finally go away, I close Visual Studio 2017, I clean the project, I build it again, I close VS 2017 again.

Then suddenly, the error goes away.

Could anybody suggest how I could investigate what's causing these errors and finally make them go away?
Comment 1 antoniocaroppos 2017-11-13 12:58:55 UTC
CellEditor.xaml looks like this:

<?xml version="1.0" encoding="utf-8"?>
<ContentPage xmlns="http://xamarin.com/schemas/2014/forms" xmlns:x="http://schemas.microsoft.com/winfx/2009/xaml" x:Class="MyApp.CellEditor" Title="{Binding Name}">
	<StackLayout Margin="20" VerticalOptions="StartAndExpand">
		<Label Text="Name" />
		<Entry Text="{Binding Name}" />
		<Label Text="Notes" />
		<Entry Text="{Binding Notes}" />
		<Label Text="Done" />
		<Switch IsToggled="{Binding Done}" />
		<Button Text="Save" Clicked="OnSaveClicked" />
		<Button Text="Delete" Clicked="OnDeleteClicked" />
		<Button Text="Cancel" Clicked="OnCancelClicked" />
		<Button Text="Speak" Clicked="OnSpeakClicked" />
	</StackLayout>
</ContentPage>

Does this help, or which other files should I post?