Bug 60607 - Auto inside fixed height view does not calculate correctly
Summary: Auto inside fixed height view does not calculate correctly
Status: RESOLVED NORESPONSE
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 2.4.0
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-11-10 00:17 UTC by Lewis Kwong
Modified: 2017-12-14 00:39 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: Yes
Last known good build: 2.3.4.267


Attachments
Project and Monitor screenshot of top views viewgroup (1.20 MB, application/x-zip-compressed)
2017-11-10 00:17 UTC, Lewis Kwong
Details
Screenshots (26.92 KB, application/x-zip-compressed)
2017-11-10 01:06 UTC, Paul DiPietro [MSFT]
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description Lewis Kwong 2017-11-10 00:17:19 UTC
Created attachment 25625 [details]
Project and Monitor screenshot of top views viewgroup

Tested on Android 6.0 VS Emulator

Reproduction Steps:

1. Open application
2. Observe teal area is the header background color
3. The Text "Test@..." is in the bottom viewgroup while the label "Subtitle" is in the above.



Inside the attached project is a reproduction project and an image showing the bounds of the top viewgroup.

From what I observe it looks like the "Auto" Property does not factor in the parents fixed height, in this circumstance * seems resolve this issue.

Was originally observed when moving from 2.3.4.267 -> 2.4.0.282
Comment 1 Paul DiPietro [MSFT] 2017-11-10 01:06:33 UTC
Using your project the result is the same on both 2.3.4.267 and 2.4.0 on an Android 6.0/API23 emulator. Is there something I'm missing? I will attach two screenshots.
Comment 2 Paul DiPietro [MSFT] 2017-11-10 01:06:46 UTC
Created attachment 25626 [details]
Screenshots
Comment 3 Lewis Kwong 2017-11-10 03:14:11 UTC
I will confirm next week with my team member which originally observed this bug. Will get back to you on the versions etc.
Comment 4 Paul DiPietro [MSFT] 2017-12-14 00:39:43 UTC
As we haven't heard back for over a month, we will close this for the time being. Please reopen when there is more information which can be provided, assuming this is still an issue as of the latest 2.5.0 stable release of Forms. Thanks!