Bug 6060 - Double click stops working throughout the application
Summary: Double click stops working throughout the application
Status: RESOLVED DUPLICATE of bug 4470
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: 3.0.x
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-07-10 12:18 UTC by Adam Kemp
Modified: 2012-09-10 04:32 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 4470

Description Adam Kemp 2012-07-10 12:18:15 UTC
I wish I could tell you the steps to reproduce this reliably, but all I know is that this has happened to me three separate times, and a few other developers on my team have reported the same thing. Every once in a while MonoDevelop gets into a state in which double click stops working throughout the entire app. I can't double click to open a file, to select text in the editor, so jump to an error in the error list, or to do anything else that requires a double click.

The worst part is that I can't find anything to make it start working again short of actually rebooting my computer. Quitting the application and restarting it doesn't work. Logging out and back in doesn't work. Only restarting seems to work. I have no idea why that would make it start working again, and I'm sure there must be something I could do that would simulate a restart of the computer as far as MonoDevelop is concerned, but I can't figure out what that would be. I don't even understand why such steps would ever be required. What kind of state information is being persisted out of process that would affect double click? It boggles the mind...
Comment 1 Mikayla Hutchinson [MSFT] 2012-07-10 14:08:56 UTC
The double-click depends on a timestamp value that's based on the uptime, and there's a known issue when it overflows int32.

*** This bug has been marked as a duplicate of bug 4470 ***
Comment 2 Brian G 2012-08-08 16:16:30 UTC
Just noting that I'm seeing this issue too. August 8, 2012
Comment 3 Franklynw 2012-09-10 04:32:26 UTC
Me too - version 3.0.3.5, Sept 2012