Bug 606 - Alt-arrow word navigation doesn't work in GTK text widgets
Summary: Alt-arrow word navigation doesn't work in GTK text widgets
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: unspecified
Hardware: Macintosh Mac OS
: Low normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2011-09-02 09:34 UTC by Michael Natterer
Modified: 2012-01-03 14:41 UTC (History)
4 users (show)

Tags: gtk
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Michael Natterer 2011-09-02 09:34:42 UTC
Summary says it all, the reason is that the quartz backend fails to ever deliver Alt as modifier, see these upstream issues:

https://bugzilla.gnome.org/show_bug.cgi?id=607115
https://bugzilla.gnome.org/show_bug.cgi?id=605799
Comment 1 Michael Natterer 2011-09-15 06:34:55 UTC
There is now a patch attached to
https://bugzilla.gnome.org/show_bug.cgi?id=605799
which fixes the issue. Will push to upstream as soon as approved.
Comment 2 Mikayla Hutchinson [MSFT] 2012-01-03 14:41:51 UTC
This should be fixed by the GTK+ version that's currently in Mono beta, so I'm marking it fixed. Please re-open if it happens with GTK+ version is 2.24.8 or later. GTK+ version can be found in the MD About dialog.