Bug 60575 - Collection Type Attached Properties Can't be Filled in XAML
Summary: Collection Type Attached Properties Can't be Filled in XAML
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 2.4.0
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Stephane Delcroix
URL:
Depends on:
Blocks:
 
Reported: 2017-11-08 19:01 UTC by Charles Petzold
Modified: 2017-12-22 02:05 UTC (History)
3 users (show)

Tags: ac fr
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Charles Petzold 2017-11-08 19:01:27 UTC
The following program contains a class named TestClass that defines two attached bindable properties, SimpleProp of type string, and CollectionProp of type IList<string>:

https://github.com/xamarin/private-samples/tree/master/AttachedProperties

The MainPage.xaml file sets these properties in two Buttons using property-element syntax, and the Clicked events show their contents.

As is, the program works, but CollectionProp is empty. When the contents of CollectionProp in MainPage.xaml are uncommented, a XAML compilation error of "Property CollectionProp not found" results. When XAML compilation is turned off, then the contents of the page do not appear.
Comment 1 Paul DiPietro [MSFT] 2017-11-08 19:12:27 UTC
Will assign to Stephane to look at when he gets a chance.
Comment 2 Samantha Houts [MSFT] 2017-11-11 00:17:47 UTC
https://github.com/xamarin/Xamarin.Forms/pull/1262
Comment 3 Samantha Houts [MSFT] 2017-12-22 02:05:05 UTC
https://github.com/xamarin/Xamarin.Forms/pull/1290

Should be fixed in 2.6.0-pre1. Thanks!