Bug 60532 - Switch not visible
Summary: Switch not visible
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Android ()
Version: 2.5.0
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL: https://stackoverflow.com/questions/4...
Depends on:
Blocks:
 
Reported: 2017-11-06 17:02 UTC by eric
Modified: 2017-11-13 17:09 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description eric 2017-11-06 17:02:40 UTC

    
Comment 1 eric 2017-11-06 17:03:58 UTC
I updated to new version of the xamarin forms, but now the swithes look like this when enabled=false:

http://prntscr.com/h6y6vr

Version:2.5.0.19271-pre2

This is a Bug?
Comment 2 Paul DiPietro [MSFT] 2017-11-06 17:18:32 UTC
Can you please give us a reproduction with more info? Devices this occurs on? Versions? Have you tried various versions of the support libraries to see if any changes occur?
Comment 3 Paul DiPietro [MSFT] 2017-11-06 17:19:20 UTC
This is of course this occurs on Android. If iOS, please note as such.
Comment 4 eric 2017-11-07 08:56:45 UTC
Hello,
Sorry for the late response.
I have tried on the Nexus 4(Jelly Bean) Android 4.1 API16 and Nexus 7(Lollipop) android 5.1.0 API 22, both emulators, and i tried on my phone that has android 7.0 and OS ZUI 2.5.
What do you mean by diferent support libraries?
Comment 5 eric 2017-11-07 10:42:27 UTC
I created a black project with the Switches and is the same.
Comment 6 Paul DiPietro [MSFT] 2017-11-07 17:59:40 UTC
Can you please upload that project? By support libraries, I mean the Xamarin.Android.Support.v4/v7 packages.
Comment 7 eric 2017-11-08 08:17:29 UTC
Here is the app just with the switches:
https://we.tl/Dk7aid79nb
Comment 8 eric 2017-11-09 08:16:10 UTC
So, the problem was reproduced by you?
Comment 9 Paul DiPietro [MSFT] 2017-11-09 16:24:37 UTC
There are no apparent visible changes between 2.3.4 and 2.5 on an API 21 simulator. Those are what the AppCompat switches look like.
Comment 10 eric 2017-11-10 09:18:47 UTC
They look like the switches in the print screen of my first post?
I can even see the pendulum.
Comment 11 eric 2017-11-13 15:46:04 UTC
The switches should be like this:
http://prntscr.com/h9xcyq
Comment 12 eric 2017-11-13 17:09:47 UTC
Now is working, I had to install first the support libraries to the last version, then I updated xamarin forms, now works fine.