Bug 60404 - cannot load Azure management sdk from assembly
Summary: cannot load Azure management sdk from assembly
Status: RESOLVED NORESPONSE
Alias: None
Product: Class Libraries
Classification: Mono
Component: General ()
Version: 5.4 (2017-06)
Hardware: PC Linux
: Normal normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-10-27 01:12 UTC by jake22599
Modified: 2018-03-13 11:07 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description jake22599 2017-10-27 01:12:32 UTC
I'm having issues running a binary compiled in Visual Studio. It uses Azure Service Bus and management SDK. Its works on Windows Mono but not on Ubuntu. The solution is compiled using .Net Framework 4.6. It runs properly on windows.

I download Mono-Runtime on Ubuntu and tried to run on console. This is the error i get.


Could not load signature of Microsoft.Rest.TokenCredentials:ProcessHttpRequestAsync due to: Could not load file or assembly 'System.Net.Http, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. assembly:System.Net.Http, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a type:<unknown type> member:<none>

Unhandled Exception:
System.TypeLoadException: Could not load type 'Microsoft.Rest.TokenCredentials' from assembly ''.
  at TestProject.ServiceBusManager..ctor () [0x00022] in <361059fca0ba4fdb9746f81f381c6004>:0 
  at Example.Program.Main (System.String[] args) [0x00019] in <4839397d23d646a0b5d49866c41eba66>:0 
[ERROR] FATAL UNHANDLED EXCEPTION: System.TypeLoadException: Could not load type 'Microsoft.Rest.TokenCredentials' from assembly ''.
  at TestProject.ServiceBusManager..ctor () [0x00022] in <361059fca0ba4fdb9746f81f381c6004>:0 
  at Example.Program.Main (System.String[] args) [0x00019] in <4839397d23d646a0b5d49866c41eba66>:0


https://github.com/Azure/azure-service-bus/issues/108
https://stackoverflow.com/questions/46952379/c-sharp-binary-using-azure-running-on-ubuntu-using-mono
Comment 1 Marek Safar 2017-11-16 11:12:51 UTC
This looks like they are packaging non-portable version of assemblies. If you attach full repro we can investigate further.
Comment 2 Marek Safar 2018-03-13 11:07:09 UTC
We have not received the requested information. If you are still experiencing this issue please provide all the requested information and reopen the bug report.

Thank you!