Bug 60322 - Xamarin.Forms 2.4 is loosing hidden entry background on iOS
Summary: Xamarin.Forms 2.4 is loosing hidden entry background on iOS
Status: RESOLVED DUPLICATE of bug 60261
Alias: None
Product: Forms
Classification: Xamarin
Component: iOS ()
Version: 2.4.0
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-10-23 13:33 UTC by Rafal Grzybowski
Modified: 2017-10-23 14:32 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Sample solution demonstrating the problem (5.43 MB, application/zip)
2017-10-23 13:33 UTC, Rafal Grzybowski
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 60261

Description Rafal Grzybowski 2017-10-23 13:33:16 UTC
Created attachment 25403 [details]
Sample solution demonstrating the problem

Recently I have switched to Xamarin.Forms 2.4.0.18342 and now on iOS (10 and 11) the default white background for Entry controls is lost if the control was hidden and then shown.

A simple layout:

    <StackLayout Orientation="Vertical" Padding="50">
        <Button Text="Hide" Clicked="OnHideClicked"/>
        <Button Text="Show" Clicked="OnShowClicked"/>
        <Entry x:Name="PasswordEntry" Placeholder="Password" HeightRequest="44" AutomationId="PasswordStyleId" IsVisible="true"/>
    </StackLayout>

looks like this:

https://i.stack.imgur.com/XKBjc.png

But if I tap the Hide and then Show buttons with the following code behind:

    void OnHideClicked(object sender, System.EventArgs e)
    {
        PasswordEntry.IsVisible = false;
    }

    void OnShowClicked(object sender, System.EventArgs e)
    {
        PasswordEntry.IsVisible = true;
    }

the white background is no longer there:

https://i.stack.imgur.com/VFT5C.png

It works fine on Xamarin.Forms 2.3.4.270, but breaks on 2.4.0.280.
Comment 1 Paul DiPietro [MSFT] 2017-10-23 14:32:59 UTC

*** This bug has been marked as a duplicate of bug 60261 ***