Bug 60315 - HttpClient 4.3.2 broken on Mono
Summary: HttpClient 4.3.2 broken on Mono
Status: RESOLVED FIXED
Alias: None
Product: Tools
Classification: Mono
Component: msbuild ()
Version: 5.4 (2017-06)
Hardware: PC All
: --- major
Target Milestone: Future Cycle (TBD)
Assignee: Ankit Jain
URL:
Depends on:
Blocks:
 
Reported: 2017-10-23 08:29 UTC by fendant
Modified: 2018-02-22 21:59 UTC (History)
11 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description fendant 2017-10-23 08:29:47 UTC
HttpClient appears to be broken when running on Mono with the latest release.

See https://github.com/dotnet/corefx/issues/19914

Repro (from stefan-schweiger): https://github.com/stefan-schweiger/mono-http-core-repro
Comment 2 Marek Safar 2017-10-25 14:15:16 UTC
This is due to the way how we bundle Microsoft.NET.Build.Extensions. It contains .NET framework specific implementation of core libraries which when used on Mono fail.

We should not distribute their version at all as we already have correct version in mono.

One of the exhibits is the presence of full System.Net.Http.dll assembly in net461/lib but there are more in this or other folders (System.IO.Compression, System.Runtime.InteropServices.RuntimeInformation, etc)
Comment 4 smoogipoo 2017-11-30 03:24:19 UTC
No resolution beyond hacks for this critical issue yet?
Comment 5 Karin 2018-01-19 08:16:35 UTC
I also would appreciate a solution for that problem.

As a workaround the following works for me:

Include this into the UITest project file:

<Target Name="AfterBuild">  
   <Delete Files="bin/$(Configuration)/System.Net.Http.dll" /> 
</Target>
Comment 6 Rui Marinho 2018-01-19 11:41:52 UTC
this is breaking all uitest running locally, we should fix this ASAP. as Xamarin.Forms now is netstandard 2.0 it will break all our users when they upgrade.
Comment 7 Marek Safar 2018-01-19 13:41:30 UTC
Ankit, could you look into this ASAP
Comment 8 marius 2018-02-22 21:32:41 UTC
This also affects 5.8.0.108
Comment 9 Marek Safar 2018-02-22 21:59:30 UTC
This should be fixed in Mono 5.12 and newer