Bug 6028 - Mono crashes in debug mode when Stream parameter is processed
Summary: Mono crashes in debug mode when Stream parameter is processed
Status: RESOLVED FIXED
Alias: None
Product: Runtime
Classification: Mono
Component: Debugger ()
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2012-07-07 06:20 UTC by pinggi
Modified: 2015-02-20 12:29 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Mono crash (44.00 KB, image/png)
2012-07-07 06:21 UTC, pinggi
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description pinggi 2012-07-07 06:20:31 UTC
I think it's clear from the image. Monodevelop tries to evalute the "PositionPointer" property and it causes mono.exe to stop working.
Comment 1 pinggi 2012-07-07 06:21:06 UTC
Created attachment 2170 [details]
Mono crash
Comment 2 Zoltan Varga 2012-08-07 17:28:05 UTC
What mono version is this ? Does this happen every time ?
Comment 3 pinggi 2012-08-13 18:05:20 UTC
Mono-2.10.8

It happens every time when I am trying to debug my app. Evaluating of Stream object in debug mode ends up with mono crash. It loads images from the resource stream...:

Stream resourceStream = Assembly.GetExecutingAssembly().GetManifestResourceStream(name);
image = Images.LoadImage(resourceStream);


...and in the output window at the end of the text is then written:


* Assertion: should not be reached at debugger-agent.c:5195

This application has requested the Runtime to terminate it in an unusual way.
Please contact the application's support team for more information.
Comment 4 Zoltan Varga 2012-08-13 19:33:55 UTC
This was already fixed in mono master, now it should be fixed on the 2.10 branch as well by
67f377f0b7ae936e0258bfacb7dcc11fb4ab8bc0.