Bug 60275 - after upgrade to vs 15.4 app crashes on startup in simulator or on device
Summary: after upgrade to vs 15.4 app crashes on startup in simulator or on device
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: iOS
Classification: Xamarin
Component: General ()
Version: XI 11.4 (d15-5)
Hardware: PC Windows
: --- critical
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-10-19 18:11 UTC by bblonchek
Modified: 2017-10-23 18:14 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
log files (8.30 KB, application/x-zip-compressed)
2017-10-19 18:11 UTC, bblonchek
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description bblonchek 2017-10-19 18:11:27 UTC
# Steps to reproduce
upgrade
build
run on simulator
crash

# Expected behavior


# Actual behavior


# Supplemental info (logs, images, videos)


# Test environment (full version information)
Comment 1 bblonchek 2017-10-19 18:11:57 UTC
Created attachment 25373 [details]
log files
Comment 2 Manuel de la Peña [MSFT] 2017-10-23 11:41:22 UTC
Helo,

Can you please provide the full information of your environment to be able to pinpoint a specific version and a small test case of the crash. It does look to be network related which was changed a few versions ago and I would need this information to know the code you are running. 

WE do know there are some changes in ssh but I would need to get a code sample to ensure that is the issue.
Comment 3 bblonchek 2017-10-23 18:14:39 UTC
Can't seem to reproduce it anymore. Have no idea what fixed it. Perhaps all the restarts/reboots, recreation of provisioning profiles, etc. did the trick.

Very frustrating that this seems to be a recurring theme for each Xamarin upgrade.