Bug 60190 - Xamarin Mac Agent losing connection or freezes during build when "doesn't like" included resources
Summary: Xamarin Mac Agent losing connection or freezes during build when "doesn't lik...
Status: VERIFIED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: XMA ()
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-10-14 12:59 UTC by Nick Kovalsky
Modified: 2017-10-27 11:46 UTC (History)
7 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
add this file to iOS resource and enjoy tying to build from Windows (202 bytes, application/octet-stream)
2017-10-14 12:59 UTC, Nick Kovalsky
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Nick Kovalsky 2017-10-14 12:59:01 UTC
Created attachment 25307 [details]
add this file to iOS resource and enjoy tying to build from Windows

This becomes more and more frustrating fighting xamarin MacAgent bugs when building for iOS from Windows.. With those build freezes then killing VS process 50 times a day, other nice freezes due to bad resources names (you mistake and put a Cyrillic "х" instead of latin "x" in a filename), now today i have fought a constant MacAgent disconnects during build with just one specific project. 
That was a real something as other solutions for iOS built fine and with just one specific solution MacAgent was just disconnecting shortly after build was started. 
So after my working day was totally messed up finally i found the cause: a small file without extension i just added to project yesterday to take a quick text note was causing this pain. 
Once file was excluded - disconnects during build were gone. Incredible architecture with all my due respect.
Comment 1 Nick Kovalsky 2017-10-14 13:04:02 UTC
A quick note, with such resources it build fine when building from a mac, with Visual Studio for Mac.
Comment 2 mag@xamarin.com 2017-10-17 19:15:31 UTC
Hi.

Confirming that I was able to reproduce the issue consistently with the provided file.

However, given many improvements we have been doing for the next 15.5 release related to the connection experience, build experience, reconnection mechanism, timeouts, etc., I was not able to get any VS freeze or need to kill the devenv or MSBuild process in order to be able to perform another build or action in VS. Even if this is good, it doesn't fix the reported problem so I will be investigating and working on it to provide a solution for the next release as well.

Also, given that you are being frustrated fighting against Mac Agent bugs, we encourage you to please report any bug that you face, with the correct repro steps in order to identify it and fix it if we haven't done it already.

Finally, as I mentioned, many fixes and improvements related to XMA will be introduced through the 15.5 version, which should provide a way better experience. Hopefully most of your current issues disappear after the mentioned release.

Thanks
Comment 3 xamarin-release-manager 2017-10-23 20:23:36 UTC
Fixed in version 4.9.0.345 (master)

Author: Mauro Agnoletti
Commit: a450405c29da672b3bb9c0988b57908c00a44197 (xamarin/XamarinVS)
Comment 4 mag@xamarin.com 2017-10-25 03:26:36 UTC
Hi,

The issue has been fixed on master branch and will be included in the next 15.5 preview.

However, the root issue was not exactly as you pointed: "a small file without extension i just added to project yesterday to take a quick text note was causing this pain."

The real issue was that any resource file which file name contains Unicode chars different from the first 127 code points (ASCII chars and symbols), will cause the build to fail and the Build Agent on the Mac to crash and restart.
The reason for this was that the underlying MQTT protocol that we use to communicate was not encoding those code points correctly, causing the message topics parsing to fail in a fatal way.

The issue has been addressed and fixed correctly and should be included from the next 15.5 preview.

Thanks