Bug 60104 - Problem with suspending thread that was attached/detached when unloading domain
Summary: Problem with suspending thread that was attached/detached when unloading domain
Status: NEEDINFO
Alias: None
Product: Runtime
Classification: Mono
Component: GC ()
Version: 5.2 (2017-04)
Hardware: PC Windows
: Normal normal
Target Milestone: Future Cycle (TBD)
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-10-10 20:23 UTC by Michael Stoyke
Modified: 2017-11-08 21:21 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Diff of the change I applied (597 bytes, patch)
2017-10-10 20:23 UTC, Michael Stoyke
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 60104 on GitHub or Developer Community if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: GitHub Markdown or Developer Community HTML
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
NEEDINFO

Description Michael Stoyke 2017-10-10 20:23:45 UTC
Created attachment 25257 [details]
Diff of the change I applied

We are using Mono as an embedded runtime and ran into this problem:
An app domain is created and some assemblies are loaded on the main thread. Then we create another thread and attach/detach the new thread to that app domain.

When unloading the app domain later on the main thread (after the other thread was detached and has ended) the thread state machine fails in mono_threads_transition_request_async_suspension() trying to suspend a thread that's in state STATE_ASYNC_SUSPEND_REQUESTED.

I've attached a potential fix to this ticket, but I wouldn't be surprised if this hackfix just hides the symptoms instead of solving the underlying problem.

We are using SGEN and have defined/enabled HAVE_CONC_GC_AS_DEFAULT
Comment 1 Ludovic Henry 2017-11-08 21:21:21 UTC
Hi,

Unfortunately the diff you applied only hides the symptoms, and isn't a fix for the actual bug. Could you provide us with a repro case? Or some stacktraces?

Thank you,