Bug 60074 - Xamarin UI Test: Tap() method bug
Summary: Xamarin UI Test: Tap() method bug
Status: RESOLVED DUPLICATE of bug 60050
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 2.3.4
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2017-10-10 05:37 UTC by developer.lorenz
Modified: 2017-10-10 11:15 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
XAML PAGE (34.04 KB, image/png)
2017-10-10 05:37 UTC, developer.lorenz
Details
UI Test code screenshot (4.85 KB, image/png)
2017-10-10 05:39 UTC, developer.lorenz
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 60050

Description developer.lorenz 2017-10-10 05:37:19 UTC
Created attachment 25233 [details]
XAML PAGE

I'm currently working with UI Testing with Xamarin UI Test. I'm currently having a problem with the Tap() method with my test, below is my current scenario.

UI TEST GOAL:
Enter phone number in the textbox and then button will be enabled once the text box is not empty and should trigger the Tap("startPageProceedButton") method when doing the UI test.

Button uses triggers and behaviors(Data triggers to be specific) and the button's state(enabled/disabled) depends on the textbox's state whether its empty or not.

CURRENT SCENARIO:
The Tap() method for the button is not triggered when running the UI test even when the textbox is already filled with data.

The textbox also uses behaviors feature like the code below.

<Entry.Behaviors>
    <behaviors:CommonEntryValidatorBehavior
        x:Name="MobileEntryValidator"
        MinLength="10"
        IsFixedLength="True"
        IsNumberOnly="True"/>
</Entry.Behaviors>


NOTE:
I'm using Xamarin.Forms v2.3.4.247. I'm currently testing on the Android platform.

Its weird because the Tap() method is triggered/working when it is the only method in the test method and the app.EnterText() is commented out. Like the following:

[Test]
public void EnterCustomerNumberAndProceed()
{
   //app.EnterText("txtPhoneNumber", "9999999999");
   app.Tap("startPageProceedButton");
}


Another thing that made me curious if this is a bug is that when I created a new xamarin forms project without using the behaviors and triggers the UI test works fine.


IS THIS IS A BUG WITH THE UI TEST PART?

Please check the images attached to this issue.
Comment 1 developer.lorenz 2017-10-10 05:39:36 UTC
Created attachment 25234 [details]
UI Test code screenshot
Comment 2 Paul DiPietro [MSFT] 2017-10-10 11:15:24 UTC

*** This bug has been marked as a duplicate of bug 60050 ***