Bug 60057 - [Scoped Regression] Xamarin Platform Regression Test Plan -> Xamarin Studio Full (Mac | XS) -> Mobile Development › Android › F# Support ->Breakpoint not hit for Android App F# template for Simulator and device both
Summary: [Scoped Regression] Xamarin Platform Regression Test Plan -> Xamarin Studio F...
Status: CONFIRMED
Alias: None
Product: Android
Classification: Xamarin
Component: Debugger ()
Version: unspecified
Hardware: PC Mac OS
: High major
Target Milestone: 15.7
Assignee: Zoltan Varga
URL:
Depends on:
Blocks:
 
Reported: 2017-10-09 12:53 UTC by Swati Gangrade
Modified: 2018-02-02 13:32 UTC (History)
6 users (show)

Tags: Globallogic
Is this bug a regression?: Yes
Last known good build:


Attachments
IDELogs (11.28 KB, application/zip)
2017-10-09 12:53 UTC, Swati Gangrade
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 60057 on Developer Community or GitHub if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
CONFIRMED

Description Swati Gangrade 2017-10-09 12:53:31 UTC
Created attachment 25225 [details]
IDELogs

Bug Description-
Debugger is not hit for Android FSharp template for simulator and device both

===============================================================================================================================
Build Version - 
Mac OS High Sierra Version 10.13 
Xamarin.Android Version : 8.1.0-19
Visual Studio for Mac Version - 7.3.0.665
Mono Framework-MDK-5.4.0.204.macos10.xamarin.universal
Xamarin.iOS Version : 11.4.0.80
Xamarin Mac Version-4.0.0.80

Build Details- https://gist.github.com/gangrade-swati/5bf25bdbf08f31036dccfb0b82074d54

Builds taken from:  https://github.com/xamarin/release-manifests/blob/d15-5/d15-5/2017-10-05_213230-15.5-scoped-regression.json

===============================================================================================================================
Steps to Repro-
1. Launch VSFM
2. Create Android Sharp language project via  File > New Solution > Android > App >Android App(F# Language)
3. Put a breakpoint in .fs class while anywhere 
4. Select simulator or device as Deployment target device
5. Click Run button

Actual Result- Appliocaiton is deployed successfully in simulator and device both but debugger is not fitted

Expected Result-Application should be deployed and debugger should be hit 
===============================================================================================================================

Application Output Gist Link - https://gist.github.com/gangrade-swati/6685c9a8d60ec350e93f51c99ef923a2

Deploying Device Pad Logs- https://gist.github.com/gangrade-swati/11938aa61c88b937a8a7d5e1f063aa00

===============================================================================================================================

Test Case-https://testrail.xamarin.com/index.php?/tests/view/16891299

Test Plan- https://testrail.xamarin.com/index.php?/plans/view/51220
===============================================================================================================================

Reproducibility-100%

Screencast-https://www.screencast.com/t/UcqMzwnWoflm

Attached logs
Comment 1 Swati Gangrade 2017-10-09 12:53:57 UTC
Kindly Note-

As of now I am not updating the Last Known good build field as such kind of test case is not executed earlier. So will update the last known build tomorrow
Comment 2 dean.ellis 2017-10-09 14:47:56 UTC
The pdb file is being deployed...

"    DEBUG NotifySync CopyFile /Users/globallogic/Projects/AndroidFSharpApp2/AndroidFSharpApp2/obj/Debug/android/assets/AndroidFSharpApp2.pdb /storage/emulated/0/Android/data/com.xamarin.AndroidFSharpApp2/files/.__override__/AndroidFSharpApp2.pdb 1316"

so no idea why the break points are not being hit.
Comment 3 Gaurav Ganorkar 2017-10-10 06:45:05 UTC
Hello Dean Ellis

I verified this issue in today's build bug is still persists.

Build Info-
Mono 5.4.0.212 (2017-06/fbc487ff424) (64-bit)
VSMac Version 7.3 Preview (7.3 build 676)
XA Version: 8.1.0.19 (Visual Studio Enterprise)
XI Version: 11.4.0.84 (Visual Studio Enterprise)
XM Version: 4.0.0.84 (Visual Studio Enterprise)

Build Details-https://gist.github.com/GLjackyvaswani/d80493985c33f21085c6a3f8e2eafa2b 

So kindly let me know additional info is required
Comment 4 Jason Imison 2018-02-02 13:32:46 UTC
There was previously an issue with the .pdb file not being output to the /bin/Debug folder. This has since been fixed.